Angular + internet explorer 9 The provided animation property “transform” is not a supported CSS property for animations

I have an angular project 7.14, and i want to make it compatible with ie11,10 and 9, but on 9 I cant open dialogs of angular material, these errors appears on the console:

ERROR Error: The animation trigger “dialogContainer” has failed to build due to the following errors: The provided animation property “transform” is not a supported CSS property for animations. I read that ie9 doesnt support animations so I remove the animation-js pollyfills and uninstall this one, but some animations are available yet.