BAT or Entity module problem?

can you help me with this error: “Fatal error: Declaration of BatTypeController::save($ entity) must be compatible with EntityAPIController::save($ entity, ?DatabaseTransaction $ transaction = NULL) in /usr/local/www/nginx-dist/drupal/sites/all/modules/bat/modules/bat_unit/bat_unit.module on line 1999” line 1999 is: /** * The Controller for BatType entities. */ class BatTypeController extends EntityAPIController {

/** * */ public function __construct($ entityType) { parent::__construct($ entityType); }

Thanks in advice