Building an LWJGL jar file – java.lang.NoClassDefFoundError

Recently, I’ve been in my head about LWJGL and creating games, and have made a simple test thingy. I tried to build the jar using eclipse, but when I run the jar file, it errors out. When I use Command Prompt, this is the output:

D:\>java -jar testing.jar Picked up _JAVA_OPTIONS: -Xmx8192M Error: A JNI error has occurred, please check your installation and try again Exception in thread "main" java.lang.NoClassDefFoundError: org/lwjgl/LWJGLException         at java.lang.Class.getDeclaredMethods0(Native Method)         at java.lang.Class.privateGetDeclaredMethods(Unknown Source)         at java.lang.Class.privateGetMethodRecursive(Unknown Source)         at java.lang.Class.getMethod0(Unknown Source)         at java.lang.Class.getMethod(Unknown Source)         at sun.launcher.LauncherHelper.validateMainClass(Unknown Source)         at sun.launcher.LauncherHelper.checkAndLoadMain(Unknown Source) Caused by: java.lang.ClassNotFoundException: org.lwjgl.LWJGLException         at java.net.URLClassLoader.findClass(Unknown Source)         at java.lang.ClassLoader.loadClass(Unknown Source)         at sun.misc.Launcher$  AppClassLoader.loadClass(Unknown Source)         at java.lang.ClassLoader.loadClass(Unknown Source)         ... 7 more 

My native folder is correct, I’ve checked it.

The project runs perfectly fine in the IDE

Here’s what is in my build path:

jinput.jar lwjgl_util.jar lwgl.jar > NativeLibLoc: [Native Dir] slick-util.jar jre system library [SE-1.8] 

I don’t know what the problem is, but thank you for anyone’s help.