Can’t make requirements in composer

I’m trying to use GuzzleHttp, but I have 'Class 'GuzzleHttp\Client' not found' all the time. I googled, and everyone says to make composer require guzzlehttp/guzzle in the project folder. But when i type it in console I have

Using version ^6.3 for guzzlehttp/guzzle ./composer.json has been updated Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of  packages.   Problem 1 - don't install bower-asset/yii2-pjax 2.0.7.1|remove yiisoft/yii2-app-basic No version set (parsed as 1.0.0) - remove yiisoft/yii2-app-basic No version set (parsed as 1.0.0)|remove bower-asset/yii2-pjax 2.0.7.1 - don't install bower-asset/yii2-pjax 2.0.7.1|remove yiisoft/yii2-app-basic No version set (parsed as 1.0.0) - Installation request for yiisoft/yii2-app-basic No version set (parsed as 1.0.0) -> satisfiable by yiisoft/yii2-app-basic[No version set (parsed as 1.0.0)]. - Installation request for bower-asset/yii2-pjax (locked at 2.0.7.1) -> satisfiable by bower-asset/yii2-pjax[2.0.7.1].   Installation failed, reverting ./composer.json to its original content. 

I tried to remove this remove yiisoft/yii2-app-basic but output is
yiisoft/yii2-app-basic is not required in your composer.json and has not been removed Package "yiisoft/yii2-app-basic" listed for update is not installed. Ignoring. Loading composer repositories with package information Updating dependencies (including require-dev) Nothing to install or update Generating autoload files composer.json in my project

"require": {     "php": ">=5.4.0",     "yiisoft/yii2": "~2.0.14",     "yiisoft/yii2-bootstrap": "~2.0.0",     "yiisoft/yii2-swiftmailer": "~2.0.0 || ~2.1.0",     "guzzlehttp/guzzle": "~6.3" }, 

If it will help, I have globally installed composer via sudo apt-get install composer