Can’t mount second hdd due to error /dev/mapper/backup–mint–vg-root: can’t read superblock

I’m trying to mount second hdd. I don’t know where i’m going wrong way. first i open partition with cryptsetup sudo cryptsetup open /dev/sdb5 backup … done with pass sudo vgdisplay …got two identical vg names, according to this advice How do you mount a LVM patition that has the same VG name as my current partition I did rename vgrename M06MX4-J1Uc-ezEw-H0VQ-lXSQ-alDr-wTn623 backup-mint-vg sudo lvscan #show inactive backup-mint-vg that became active after sudo vgchange -ay but i can’t mount it

       sudo mount /dev/backup-mint-vg/root sdb5 

… and with sudo mount /dev/dm-4 sdb5 mount: /dev/mapper/backup–mint–vg-root: can’t read superblock

there are many errors:

$   sudo pvdisplay    /dev/mapper/backup: read failed after 0 of 4096 at 0: errors/IO   /dev/mapper/backup: read failed after 0 of 4096 at 119774576640:   [skip next 30 lines of same errors]   --- Physical volume ---   PV Name               /dev/mapper/backup   VG Name               backup-mint-vg   PV Size               111,55 GiB / not usable 2,00 MiB   Allocatable           yes (but full)   PE Size               4,00 MiB   Total PE              28556   Free PE               0   Allocated PE          28556   PV UUID               EQRjEE-D5jq-RVyo-bhUC-1Fp1-udWK-KG7Mdb    --- Physical volume ---   PV Name               /dev/mapper/sda5_crypt   VG Name               mint-vg   PV Size               148,57 GiB / not usable 3,00 MiB   Allocatable           yes    PE Size               4,00 MiB   Total PE              38033   Free PE               6   Allocated PE          38027   PV UUID               Z3hkoa-ACP3-GqDb-qvTu-gZqL-S90M-cWQ0sW 

How can i correct these issues? I think I should fsck -cck /dev/backup-mint-vg/root someways?