Can’t use at_step in squid config

I’m trying to configure Squid to work as a Telegram Messenger proxy using this guide. My Squid complains about their proposed config options (output of squid -k parse):

2019/05/22 11:17:20| Processing: acl DiscoverSNIHost at_step SslBump1 2019/05/22 11:17:20| FATAL: Invalid ACL type 'at_step' FATAL: Bungled /etc/squid/squid.conf line 1003: acl DiscoverSNIHost at_step SslBump1 Squid Cache (Version 3.5.27): Terminated abnormally. 

Squid website says that at_step appeared in version 3.5, so the version shouldn’t be an issue. Some forums suggest compiling Squid from source code with flags like --with-openssl and --enable-ssl-crtd to make options like at_step working. I wonder is this could be the problem. And should I, then, compile and install Squid myself?

Ubuntu 18.04.1