CentOS desktop startx no screen found on VPS

I installed Gnome/KDE/XFCE,… on CentOS 7 on a VPS

yum groupinstall "Server with GUI" yum groupinstall "GNOME Desktop" 

or

yum groupinstall "Server with GUI" yum groupinstall "Xfce" 

But when I run startx I get the following result for all desktops

xauth:  file /root/.serverauth.25989 does not exist   X.Org X Server 1.20.1 X Protocol Version 11, Revision 0 Build Operating System:  3.10.0-957.1.3.el7.x86_64 Current Operating System: Linux centos7.cs1cloud.internal 3.10.0-957.12.2.el7.x86_64 #1 SMP Tue May 14 21:24:32 UTC 2019 x86_64 Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10.0-957.12.2.el7.x86_64 root=UUID=dadd7363-eae7-4b4b-85a2-ed94705b1bed ro nomodeset crashkernel=auto rhgb quiet LANG=en_US.UTF-8 Build Date: 14 March 2019  10:37:36AM Build ID: xorg-x11-server 1.20.1-5.3.el7_6 Current version of pixman: 0.34.0         Before reporting problems, check http://wiki.x.org         to make sure that you have the latest version. Markers: (--) probed, (**) from config file, (==) default setting,         (++) from command line, (!!) notice, (II) informational,         (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (==) Log file: "/var/log/Xorg.0.log", Time: Thu May 30 08:54:16 2019 (==) Using system config directory "/usr/share/X11/xorg.conf.d" (EE) Fatal server error: (EE) no screens found(EE) (EE) Please consult the The X.Org Foundation support          at http://wiki.x.org  for help. (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information. (EE) (EE) Server terminated with error (1). Closing log file. xinit: giving up xinit: unable to connect to X server: Connection refused xinit: server error 

Appreciate for any help