Error: Inavlid template facebook.apk while using metasploit for hacking android

Hey iam learning ethical hacking recently. i installed metasploit in my ubuntu system. While iam building the payload iam getting a error : Invalid template:facebook.apk. iam using another signed apk file(like facebook or whatsapp) to inject the payload. i tried different android apps but all the time iam getting this error.

Does anyone knows what is it causing?

Thanks in advance!