Error Magento 2.3.0 upgrade ( php requirement )

I’m upgrading Magento from 2.2.7 to 2.3.0 from composer. Running in sequence

php bin/magento maintenance:enable  composer require magento/product-community-edition 2.3.0 --no-update  composer update  

In the console I read several lines of error with sentences like

magento/framework 100.1.15 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.23) does not satisfy that requirement.

Can only install one of: magento/framework[102.0.0, 101.0.0].

I’m using php v7.1.23 and don’t say nothing about issue on v 7.1.x.

So i don’t understand why the upgrade isn’t compatible.

How does this problem happen? Do I need to upgrade to php v7.2?