Exploit CVE-2020-0688 for older versions


I wanted to exploit my IIS CVE-2020-0688, which I saw that the key is the same as advertised.

The problem is that my IIS is old, and uses AppPool of .NET 2 and not .NET 4. Also I can use only GET as I don’t see a POST request using the viewstate. All the exploits in ysoserial use Microsoft.PowerShell.Editor.dll which is not loaded in the old version.

Does anyone know a gadget for .NET2?