Exploiting SQLi ActiveRecord class on a vulnerable CodeIgniter version


Im doing a box from vulnhub, found that its running a version of CodeIgniter vulnerable to SQLi. https://www.cvedetails.com/cve/CVE-2015-5725/

Im having troubles exploiting the vuln line on system/database/DB_active_rec.php

    {         $  this->ar_offset = $  offset;         $  this->ar_offset = (int) $  offset;         return $  this;     } 

https://github.com/bcit-ci/CodeIgniter/commit/0dde92def6b9f276f05ff77abb07ead318f9ec23

more or less, i have no idea where to start.