How bad or good is the name of this function: `getCoefficientsAndMeasurementsByDateRanges`

Basically, it is a getter function that I am writing in JavaScript. It gets Coefficients which is a list, also Measurements alongside.

I could separate into two getter functions, but there would be a common part.

Second point, is that there is no proper name for both, even if I multiply element by element after getting both. The second part is ByDatesRange. If we check the function specification, we will see that it returns values based on start-end range of dates. However, I think without seeing the detailed specification other developers should know what it does at least, from its name.

With this being said, it appears very long for a function name to me.

What are your thoughts ?