How can i solve php upgrade problem

I am using a plugin that works on Woocommerce.
While no error occurs on PHP 7.2 (eg 7.3) I get an error like the following in 7.2. The developer team is not helping. How can I resolve this error? It is probably caused by a foreach loop defined in the plugin. However, I am not sure how to find this cycle. I’ve been researching for about a week. I could not find a solution. I looked at a change that came with new versions of PHP. I could not see any change regarding the foreach loop. I searched for similar problem on other platforms. Unfortunately, I could not find it.

invalid argument supplied for foreach() in woocommerce/includes/wc-template-function.php on line 2735.