How to mention the magento version compatibility in composer.json

I am creating a module in magento 2 . Now i am writing composer.json . Here i write supporting php version

"require": {     "php": "~5.6.0|^7.0.0",   }, 

How to i write my module will be supported by magento version greater than 2.1 , not support by 2.0

i found

 "magento/framework": "^102.0.0", "magento/module-backend": "^101.0.0" 

What is the meaning of above lines . is it the version of magento? what is 102.0.0 means?