I appear to be completely invisible on google despite their search console claiming that I am indexed [duplicate]

I recently put the site for my web design business up on google. It’s been online for about two weeks and according to Google Search Console, has been indexed several times. Despite this, I can only find it on google if I type the actual url into google. Typing the business name verbatim doesn’t work, typing the contents of the meta description tag doesn’t work. The things that do come up are a worse match. I can type my business name perfectly and things that are off by one or more characters will show up instead. I’ve gone to the 15th page of google search results and found nothing. The google search console is even claiming that my page has 7 total impressions, with an average position of 1. I can’t tell if that’s just because of me typing the url exactly or if it’s actually organic.

Important Note: My server automatically responds with a 301 redirect to the https url when someone goes to the http url. Does the Google indexing bot mishandle this somehow?

Here is what the google search console looks like:

enter image description here

I have a sitemap.xml and a robots.txt. Google search console claims that it has discovered my URL, as a result of the sitemap.xml. I don’t understand why it will only come up in google search when I type the exact url. The contents of the meta description and meta author tags have to be unique, and they still don’t bring anything up.

I should also note that I ran lighthouse on my site and got a 95/100 on the SEO portion.