I have unmet dependies while installing firfox and I am unable to configure it out

  ~$   sudo apt-get install firefox`   [sudo] password for vdattwani:  Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:  The following packages have unmet dependencies.  firefox : Depends: libc6 (>= 2.27) but 2.23-0ubuntu11 is to be installed            Depends: libfontconfig1 (>= 2.12) but 2.11.94-0ubuntu1.1 is to be installed            Depends: libstdc++6 (>= 6) but 5.4.0-6ubuntu1~16.04.11 is to be installed E: Unable to correct problems, you have held broken packages. vdattwani@vanshs-laptop:~$    

Help me get firefox working. I have checked and tried every possible solution on the web. All have a common solution but they aren’t working.

I have tried :-

sudo apt update && sudo apt install --fix-missing