Install newer GLIB than 18 on Centos 7.5

I was please wandering if it is possible to upgrade glib version on centos 7.5 for a newer version than 18. I am trying to install an app which requires it. My question is not regarding a containerized solution but for perhaps an external repo which enables to do so or perhaps ability to directly install via rpm file.

Thank you,

James