Issue with Webfont/font-face in child theme


I’ve uploaded a free webfont to my child theme. It’s placed in a folder labelled ‘fonts’. I can’t for the life of me get it to link correctly and work.

This is the code I’m using in the child theme stylesheet

@font-face {   font-family: 'GlacialIndifference';   src: url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Regular.eot'); /* IE9 Compat Modes */   src: url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Regular.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */        url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Regular.woff2') format('woff2'), /* Super Modern Browsers */        url('http:/MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Regular.woff') format('woff'), /* Pretty Modern Browsers */        url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Regular.ttf')  format('truetype'), /* Safari, Android, iOS */        font-weight: 400;        font-style: normal; }  @font-face {   font-family: 'GlacialIndifference';   src: url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Bold.eot'); /* IE9 Compat Modes */   src: url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Bold.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */        url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Bold.woff2') format('woff2'), /* Super Modern Browsers */        url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Bold.woff') format('woff'), /* Pretty Modern Browsers */        url('https://MYWEBSITEURL.com/wp-content/themes/atmosphere-child/fonts/GlacialIndifference-Bold.ttf')  format('truetype'), /* Safari, Android, iOS */        font-weight: 700;        font-style: normal; } 

I’ve also tried the following:

@font-face {   font-family: 'GlacialIndifference';   src: url('.../fonts/GlacialIndifference-Regular.eot'); /* IE9 Compat Modes */   src: url('.../fonts/GlacialIndifference-Regular.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */        url('.../fonts/GlacialIndifference-Regular.woff2') format('woff2'), /* Super Modern Browsers */        url('.../fonts/GlacialIndifference-Regular.woff') format('woff'), /* Pretty Modern Browsers */        url('.../fonts/GlacialIndifference-Regular.ttf')  format('truetype'), /* Safari, Android, iOS */        font-weight: 400;        font-style: normal; }  @font-face {   font-family: 'GlacialIndifference';   src: url('.../fonts/GlacialIndifference-Bold.eot'); /* IE9 Compat Modes */   src: url('.../fonts/GlacialIndifference-Bold.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */        url('.../fonts/GlacialIndifference-Bold.woff2') format('woff2'), /* Super Modern Browsers */        url('.../fonts/GlacialIndifference-Bold.woff') format('woff'), /* Pretty Modern Browsers */        url('.../fonts/GlacialIndifference-Bold.ttf')  format('truetype'), /* Safari, Android, iOS */        font-weight: 700;        font-style: normal; }  

I feel like both of those snippets above should work so I’m at a loss as to what I should try next. I copied the font path directly from cPanel.

Help would be appreciated!

Cheers, Rob