Kali Linux package installation error

I installed anonsurf on Kali Linux in VMware and now i can’t use apt-get install and i can’t uninstall it or stop it i don’t know why i can’t even remove any package.
this is the error when trying to install beef-xss for example:

You might want to run ‘apt –fix-broken install’ to correct these.
The following packages have unmet dependencies:
beef : Depends: libcattle-1.0-0 (>= 1.2.0) but it is not going to be installed
kali-anonsurf : Depends: i2p but it is not going to be installed
Recommends: gtkdialog but it is not installable
Recommends: gufw but it is not going to be installed
E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution).

i tried the following:
apt-get remove anonsurf (unable to locate package)

rm -rf anonsurf (it worked and i the directory is deleted but anonsurf still works)

anonsurf stop

anonsurf stopi2p

  • stopping I2P services
    sudo: unknown user: i2psvc
    sudo: unable to initialize policy plugin

how to fix it
Thanks in Advance.