Lineage crashes every 2 min

my phone locks up every 2 min, then reboots to a non recoverable state. since an update.

when running logcat and grep for ‘error’:

11-21 21:35:00.188  2711  3225 E WifiHAL : Error polling socket 11-21 21:35:03.017 11999 16706 E Surface : queueBuffer: error queuing buffer to SurfaceTexture, -19 11-21 21:35:03.017 11999 16706 E ACodec  : signalError(omxError 0x80001001, internalError -19) 11-21 21:35:03.032 11999 16697 E ExoPlayerImplInternal: Internal runtime error. 11-21 21:35:03.198 13160 13160 E CrashlyticsCore: An error occurred in the uncaught exception handler 11-21 21:35:04.300 27903 27903 E ACDB-LOADER: AUDIO_SET_CALIBRATION, Error = -1 11-21 21:35:04.300 27903 27903 E ACDB-LOADER: Error: ACDB get afe custom topologies returned = -18 11-21 21:35:04.301 27903 27903 E msm8916_platform: audio_hwdep_send_cal error open 11-21 21:35:04.314 27903 27903 W EffectsFactory: Error querying effect 7d1580bd-297f-4683-9239-e475b6d1d69f on lib offload_bundle 11-21 21:35:04.475 27901 27901 E Typeface: Error mapping font file /system/fonts/DroidSansFallback.ttf 11-21 21:35:04.510  2327 27987 E mm-camera: <IMGLIB><ERROR> 1180: module_drsd_start_session: module_drsd_start_session:1180] E 11-21 21:35:04.546  2327  2327 E mm-camera: <STATS_AF ><ERROR> 87: af_haf_init: ERROR! Failed to initialize AF Alg through af_factory_create!!  11-21 21:35:04.634  2327 27995 E mm-camera: <SENSOR><ERROR> 3102: sensor_get_cur_chromatix_name_for_type: chromatix for res_idx = 0 special_mode_mask = 0     module = 4 chromatix_type = 0 is NULL 11-21 21:35:04.683  2327 28030 E mm-camera: <IMGLIB><ERROR> 1180: module_drsd_start_session: module_drsd_start_session:1180] E 11-21 21:35:04.694  2327  2327 E mm-camera: <STATS_AF ><ERROR> 87: af_haf_init: ERROR! Failed to initialize AF Alg through af_factory_create!!  11-21 21:35:04.696  2327 28039 E mm-camera: <SENSOR><ERROR> 86: port_sensor_caps_reserve: session id doesn't match: 2 : 1 11-21 21:35:04.696  2327 28039 E mm-camera: <SENSOR><ERROR> 86: port_sensor_caps_reserve: session id doesn't match: 2 : 1 11-21 21:35:04.696  2327 28039 E mm-camera: <IFACE ><ERROR> 333: iface_util_find_primary_cid: iface_util_find_primary_cid:333 error cannot find primary sensor format cids 1 11-21 21:35:04.750  2327 28040 E mm-camera: <SENSOR><ERROR> 3102: sensor_get_cur_chromatix_name_for_type: chromatix for res_idx = 0 special_mode_mask = 0     module = 4 chromatix_type = 0 is NULL 11-21 21:35:05.038 27905 27905 E QCamera : <HAL><ERROR> int32_t qcamera::QCameraPerfLock::lock_acq_timed(int32_t): 317: failed to acquire lock 11-21 21:35:05.038 27905 27905 E QCamera : <HAL><ERROR> int qcamera::QCamera2HardwareInterface::openCamera(): 2273: Failed to reserve flash for camera id: 0 11-21 21:35:05.039 27905 27905 E QCamera : <HAL><ERROR> int32_t qcamera::QCameraPerfLock::lock_acq(): 366: failed to acquire lock 11-21 21:35:05.087 27905 27905 E QCamera : <HAL><ERROR> int32_t qcamera::QCameraPerfLock::lock_acq_timed(int32_t): 317: failed to acquire lock 11-21 21:35:05.095  2327 28108 E mm-camera: <IMGLIB><ERROR> 1180: module_drsd_start_session: module_drsd_start_session:1180] E 11-21 21:35:05.105  2327  2327 E mm-camera: <STATS_AF ><ERROR> 87: af_haf_init: ERROR! Failed to initialize AF Alg through af_factory_create!!  11-21 21:35:05.113 27905 27905 E CameraBgProcService: setHalCallback: ERROR: Callback not set 11-21 21:35:05.113 27905 27905 E CameraBgProcService: setVfwCallback: ERROR: Callback not set 11-21 21:35:05.113 27905 27905 E CameraBgProcService: setHalTouchCallback: ERROR: Callback not set 

It always starts at the

WifiHAL : Error polling socket 

Lineage/addison/Moto Play unlocked