Mailpoet WordPress Plugin

We updated the Mailpoet plugin from Version 3.60.11 to Version 3.61.11 recently and our site crashed with a fatal error:

Fatal error: Uncaught TypeError: Argument 2 passed to MailPoet\WP\Functions::addFilter() must be callable, array given, called in /home/customer/ourdomain/public_html/wp-content/plugins/mailpoet/lib/Config/Initializer.php on line 182 and defined in /home/customer/www/ourdomain/public_html/wp-content/plugins/mailpoet/lib/WP/Functions.php:79 Stack trace: #0 /home/customer/www/ourdomain/public_html/wp-content/plugins/mailpoet/lib/Config/Initializer.php(182): MailPoet\WP\Functions->addFilter(‘wpmu_drop_table…’, Array) #1 /home/customer/www/ourdomain/public_html/wp-content/plugins/mailpoet/mailpoet_initializer.php(81): MailPoet\Config\Initializer->init() #2 /home/customer/www/ourdomain/public_html/wp-content/plugins/mailpoet/mailpoet.php(114): require_once(‘/home/customer/…’) #3 /home/customer/www/ourdomain/public_html/wp-settings.php(391): include_once(‘/home/customer/…’) #4 /home/customer/www/ourdomain/public_html/wp-config.php(91): requir in /home/customer/www/ourdomain/public_html/wp-content/plugins/mailpoet/lib/WP/Functions.php on line 79

We have reported the issue in the plugin’s forum on WordPress too but still haven’t received a fix. Here’s the link to the post:

https://wordpress.org/support/topic/fatal-error-while-updating-mailpoet/#post-14466785

For reference, we are using WordPress version 5.7.2 and PHP version 7.3.2

Can anybody help with the above error?

Thanks in advance