make `pip` use not-default python3.7

I know this is a question similar to those already asked many times, but I still can not get a trustable solution. I have many versions of python installed on my Ubuntu 16.04, from the 2.7 to the latest 3.7.4.

Default is the 2.7. I know I should not change the default, because others have done it and it brought issues as serious as system breakdowns. However, I have to install a software through pip:

pip install damn_software 

which requires python >= 3.6

:~$   pip install damn_software DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support  Collecting damn_software Using cached https://files.pythonhosted.org/packages/cc/19/632db1d5095a35b08ba000d63e1ceffaf56c730dbd259f021e1fb7a75f68/damn_software-0.1.8.tar.gz ERROR: Command errored out with exit status 1:  command: /usr/bin/python -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-qDPgIM/damn_software/setup.py'"'"'; __file__='"'"'/tmp/pip-install-qDPgIM/damn_software/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base pip-egg-info      cwd: /tmp/pip-install-qDPgIM/damn_software/ Complete output (1 lines): ERROR: Python (3, 5) or later is required by software-helpers for damn_software ---------------------------------------- ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output. 

I do not know how to workaround this? Maybe a symlink?