new vhost redirect to other vhost (rspamd)

actually setup a new apache vhost for a second domain on my debian vps.

Every time i browse the new domain, it redirect to my rspamd vhost. My first domain working fine, the rspamd redirect working fine but not the second tld. Its redirecting to https://mail.domain.tld/rspamd

here the 3 vhosts:

mail.domain.tld

    <VirtualHost *:80>     ServerName mail.domain.tld     RedirectPermanent http://mail.domain.tld https://mail.domain.tld/rspamd/  </VirtualHost>   <VirtualHost *:443>     ServerName mail.domain.tld     RedirectPermanent https://mail.domain.tld https://mail.domain.tld/rspamd/      ###     ### Rspamd     ###      RewriteEngine on     RewriteRule ^/rspamd$   /rspamd/ [R]      ProxyPreserveHost On     ProxyPass /rspamd http://localhost:11334/     ProxyPassReverse /rspamd http://localhost:11334/      SSLEngine on     SSLHonorCipherOrder on     SSLCertificateFile /etc/letsencrypt/live/domain.tld-0002/fullchain.pem     SSLCertificateKeyFile /etc/letsencrypt/live/domain.tld-0002/privkey.pem      Include /etc/letsencrypt/options-ssl-apache.conf  </VirtualHost> 

domain.tld

<VirtualHost *:80>          ServerName domain.tld         ServerAlias www.domain.tld         ServerAdmin webmaster@domain.tld         DocumentRoot /var/www/domain.tld/web/          #LogLevel info ssl:warn          ErrorLog $  {APACHE_LOG_DIR}/error.log         CustomLog $  {APACHE_LOG_DIR}/access.log combined  RewriteEngine on RewriteCond %{SERVER_NAME} =www.domain.tld [OR] RewriteCond %{SERVER_NAME} =domain.tld RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent] </VirtualHost>  <IfModule mod_ssl.c> <VirtualHost *:443>          ServerName domain.tld         ServerAlias www.domain.tld         ServerAdmin webmaster@domain.tld         DocumentRoot /var/www/domain.tld/web/      Alias /phpmyadmin "/usr/share/phpmyadmin/"     <Directory "/usr/share/phpmyadmin/">         Order allow,deny         Allow from all                 AuthType Basic                 AuthName "Restricted Content"                 AuthUserFile /etc/apache2/.htpasswd                 Require valid-user     </Directory>          <Directory "/var/www/domain.tld/web/">                 AllowOverride All                 Order allow,deny                 Allow from all                 Require all granted                 Options -Indexes         </Directory>           #LogLevel info ssl:warn          ErrorLog $  {APACHE_LOG_DIR}/error.log         CustomLog $  {APACHE_LOG_DIR}/access.log combined  Include /etc/letsencrypt/options-ssl-apache.conf SSLCertificateFile /etc/letsencrypt/live/domain.tld-0002/fullchain.pem SSLCertificateKeyFile /etc/letsencrypt/live/domain.tld-0002/privkey.pem  RewriteEngine On RewriteCond %{HTTP_HOST} !^www\. [NC] RewriteRule ^(.*)$   http://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]  </VirtualHost> </IfModule> 

domain2.tld:

        ServerName domain2.tld         ServerAlias www.domain2.tld         ServerAdmin webmaster@domain.tld         DocumentRoot /var/www/domain2.tld/web/          <Directory "/var/www/domain2.tld/web/">                 AllowOverride All                 Order allow,deny                 Allow from all                 Require all granted                 Options -Indexes         </Directory>       RewriteEngine On     RewriteCond %{HTTP_HOST} !^www\. [NC]     RewriteRule ^(.*)$   http://www.%{HTTP_HOST}%{REQUEST_URI} [R=301,L]           #LogLevel info ssl:warn          ErrorLog $  {APACHE_LOG_DIR}/error.log         CustomLog $  {APACHE_LOG_DIR}/access.log combined  </VirtualHost> 

Anybody know what i’m doing wrong?