Poisson GeneralizedLinearModelFit with log link, first argument not a vector, matrix or list

Question:

I’m trying to plot a graph for an exponential decay for a radioactivity experiment, so model is y=Ae^(-kt). Cross-Validated SE, suggested trying a Poisson GLM with a log link fit, and then to output mean deviance for goodness of fit. I’ve tried doing this but am getting the error:

GeneralizedLinearModelFit::notdata: The first argument is not a vector,  matrix, or a list containing a design matrix and response vector. 

And admittedly, I don’t really understand the documentation for it. And am unsure how to implement the show mean residuals part of this. The documentation shows how to output all of the deviance residuals, but not the mean of them directly.

Data

dataHist5 = {{Around[16.5, 1.5],     Around[77.8, 8.8]}, {Around[34.5, 1.5],     Around[60.5, 8.0]}, {Around[52.5, 1.5],     Around[63.8, 8.0]}, {Around[106.5, 1.5],     Around[42.4, 6.5]}, {Around[124.5, 1.5],     Around[41.7, 6.5]}, {Around[142.5, 1.5],     Around[14.6, 3.8]}, {Around[160.5, 1.5],     Around[33.9, 5.8]}, {Around[178.5, 1.5],     Around[29.4, 5.4]}, {Around[196.5, 1.5],     Around[33.5, 5.8]}, {Around[214.5, 1.5],     Around[30.9, 5.6]}, {Around[232.5, 1.5],     Around[31.1, 5.8]}, {Around[250.5, 1.5],     Around[21.5, 4.6]}, {Around[268.5, 1.5],     Around[4.3, 2.1]}, {Around[286.5, 1.5],     Around[6.4, 2.5]}, {Around[322.5, 1.5],     Around[7.5, 2.7]}, {Around[340.5, 1.5],     Around[4.5, 2.1]}, {Around[358.5, 1.5],     Around[11., 3.3]}, {Around[376.5, 1.5],     Around[14.0, 3.7]}, {Around[394.5, 1.5],     Around[14.0, 3.7]}, {Around[466.5, 1.5],     Around[0.6, 0.7]}, {Around[502.5, 1.5],     Around[2.2, 1.5]}, {Around[520.5, 1.5],     Around[9.4, 3.1]}, {Around[538.5, 1.5],     Around[4.1, 2.0]}, {Around[646.5, 1.5],     Around[2.2, 1.5]}, {Around[682.5, 1.5], Around[0.6, 0.7]}} 

Code, so far:

glm = GeneralizedLinearModelFit[dataHist5, x, x,     ExponentialFamily -> "Poisson"] // Normal Show[ListPlot[dataHist5, Plot[glm[x]]] 

I think I’m missing an argument in Plot[glm[x]]], but not sure what.