How can I downgrade network-manager from 1.2.6-0ubuntu0.16.04.3 to 1.2.2-0ubuntu0.16.04.4 on ubuntu16.04

I installed network-manager-vpnc and network-manager-vpnc-gnome for using vpn over ipsec, but when connected to the vpn, I can’t access internet on my ubuntu 16.04 machine.

So as per the issue mentioned below, there are some DNS issues with the latest version of Network-manager on Ubuntu 16.04.

Cannot connect to vpnc with network-manager 1.2.6

But the problem is when I try to run the command to install an older version of Network-manager (1.2.2-0ubuntu0.16.04.4), it throws an error:

Version '1.2.2-0ubuntu0.16.04.4' for 'network-manager' was not found

I tried installing the version 1.2.2 from tar.xz bundle. but as soon I finished the sudo make install, all networks got disabled and I was not even able to connect to wifi or any wired connection.

So can anyone help me out as how can I downgrade my network-manager?