can not find php7.2-xml or php-xml in ubuntu 14.04

I am using ubuntu 14.04 + nginx + php7.2

I suffered “call to undefined function simplexml_load_string()” due to xml module missing in php 7.2

When I using apt-cache search php7, only shows the following

  • php7.2-mysql – MySQL module for PHP
  • php7.2-cli – command-line interpreter for the PHP scripting language
  • php7.2-json – JSON module for PHP
  • php7.2-opcache – Zend OpCache module for PHP
  • php7.2-readline – readline module for PHP
  • php7.2-gd – GD module for PHP
  • php7.2-mbstring – MBSTRING module for PHP
  • php7.2-common – documentation, examples and common module for PHP
  • php7.2-fpm – server-side, HTML-embedded scripting language (FPM-CGI binary)

all the module is without xml related. I also try add-apt-repository ppa:ondrej/php and apt update

but still get E: Couldn't find any package by regex 'php7.2-xml'

please help, thanks

Unable to locate/install mbstring for Ubuntu 14.04

I’m running Ubuntu 14.04 and PHP7.2, however I am unable to install mbstring.

This is the error encountered

Reading package lists… Done

Building dependency tree

Reading state information… Done

E: Unable to locate package php7.2-mbstring

E: Couldn’t find any package by regex ‘php7.2-mbstring’

Things that I have tried

  1. Adding universe and restricted to my sources.lists

  2. Adding ppa:ondrej/apache2 and ppa:ondrej/php

  3. Reinstalling PHP7.2

  4. Restarting Apache2

  5. Uncomment extension=mbstring in php.ini

  6. Changing to extension=php_mbstring.dll and extension=php_mbstring in php.ini

  7. Install by sudo apt-get install mbstring

  8. Install by sudo apt-get install php-mbstring

  9. Install by sudo apt-get install php7.2-mbstring

Other details

  1. PHP version – PHP 7.2.17-1+ubuntu14.04.1+deb.sury.org+3 (cli) (built: Apr 10 2019 11:16:39) ( NTS )

  2. I recently just upgraded from PHP5.6 to PHP7.2. However, I have already removed and disabled PHP5.6. phpinfo() shows that I am running PHP7.2.

Need help on this! Thank you in advance.

GNOME Commander for ver. 14.04

I want to install GNOME Commander for ubuntu 14.04 with a DDR2 machine. enter image description here

screen shot with info. about why i can’t install GNOME Commander.

The following packages have unmet dependencies:

gnome-commander: Depends: gnome-commander-data (>= 1.2.8.17-1)

but 1.2.8.17-1 is to be installed 

Depends: python:any (>= 2.7.1-0ubuntu2)

but it is a virtual package 

Depends: libc6 (>= 2.14)

but 2.19-0ubuntu6.14 is to be installed 

Depends: libgcc1 (>= 1:4.1.1)

but 1:4.9.3-0ubuntu4 is to be installed 

Depends: libgdk-pixbuf2.0-0 (>= 2.22.0)

but 2.30.7-0ubuntu1.8 is to be installed 

Depends: libglib2.0-0 (>= 2.37.3)

but 2.40.2-0ubuntu1.1 is to be installed 

Depends: libgnome2-0 (>= 2.17.3)

but it is not going to be installed 

Depends: libgnomeui-0 (>= 2.22.0)

but it is not going to be installed 

Depends: libgnomevfs2-0 (>= 1:2.17.90)

but it is not going to be installed 

Depends: libgtk2.0-0 (>= 2.24.0)

but 2.24.23-0ubuntu1.4 is to be installed 

Depends: libpango-1.0-0 (>= 1.14.0)

but 1.36.3-1ubuntu1.1 is to be installed 

Depends: libpython2.7 (>= 2.7)

but 2.7.6-8ubuntu0.5 is to be installed 

Depends: libstdc++6 (>= 4.4.0)

but 4.8.4-2ubuntu1~14.04.4 is to be installed 

Depends: libtag1c2a (>= 1.5)

but 1.9.1-2 is to be installed 

I am a totell novice in unix please include detailed info. than’x a bunch!

Ubuntu 14.04 stuck at boot screen and i can’t boot windows from flash drive

Ubuntu 14.04 64 bit , stuck on the purple screen that shows the word Ubuntu and loading , and nothing happens after that , i tried to use a flash-drive that have windows 10 , trying to remove Ubuntu and install windows , but when i press f9 and select the flash drive it does nothing and enters the normal boot of Ubuntu , i checked the boot order in the bios .

Where can I get support for Ubuntu 14.04

I need help with my old Ubunutu server, I can’t find any place with a forum to ask questions about it. I only have these questions because I am trying to upgrade the server to a new one so I can use this forum properly.

Should I upgrade my server to 16.04.6 on my own and then ask for help? Will this break my website?

How could I write a kernel module for 14.04 to extend the radiotap fields?

My application specifically needs to run on Ubuntu 14.04.

According to the man page, Ubuntu only supports the following fields:

IEEE80211_RADIOTAP_TSFT

IEEE80211_RADIOTAP_FLAGS

IEEE80211_RADIOTAP_RATE

IEEE80211_RADIOTAP_CHANNEL

IEEE80211_RADIOTAP_DBM_ANTSIGNAL

IEEE80211_RADIOTAP_DBM_ANTNOISE

IEEE80211_RADIOTAP_DBM_TX_POWER

IEEE80211_RADIOTAP_ANTENNA

IEEE80211_RADIOTAP_DB_ANTSIGNAL

IEEE80211_RADIOTAP_DB_ANTNOISE

IEEE80211_RADIOTAP_XCHANNEL

I want to write a kernel module that will supply the VHT and MCS fields if the driver can provide them.

I’ve written kernel modules before, but it’s been a while, and I’m not sure exactly where to start for network stuff. I would appreciate a general outline if anyone is able to give it.

“No network devices available” Ubuntu 14.04

I am having an issue connecting to WiFi on my Ubuntu 14.04 system. I have gotten this issue before when a software update was installed and back then I would just use an older kernel in which the network was working. However, now out of all the kernels I have 3 of them do not have network devices available, and 1 of them (the one which I used to use that had network devices available) just turns black when I try to boot it, and doesn’t even go to the login page. I’ve tried multiple solutions online to the same question but it seems like most people have Ubuntu 16.04 and those solutions don’t seem to be working with my machine. The few solutions I have found for 14.04 are very confusing to me or rely on having an old kernel in which the network devices are available. Any help or suggestions would be greatly appreciated as I really need my wireless network to start working again.

Did MySql remove support for installing MySql-5.7 on Ubuntu 14.04?

I’ve been testing an upgrade path for my Ubuntu 14.04 system to 16.04 and part of that is upgrading from MySql(5.6) to MySql(5.7).

A couple of days ago I ran through a test and had no issues upgrading to 5.7.

Following the steps on 14.04:

  • download the mysql-apt-info deb package
  • dpkg -i mysql-apt-info_0.8.13-1_all.deb
  • set the mysql version to 5.7 in the apt config interface
  • apt update
  • apt install mysql-server

I know that the mysql-apt-info package creates an apt.conf.d file that tells apt to look at a specific repo for the deb packages. My /etc/apt/sources.list.d/mysql.list is the following

deb http://repo.mysql.com/apt/ubuntu/ trusty mysql-apt-config deb http://repo.mysql.com/apt/ubuntu/ trusty mysql-5.7 deb http://repo.mysql.com/apt/ubuntu/ trusty mysql-tools #deb http://repo.mysql.com/apt/ubuntu/ trusty mysql-tools-preview deb-src http://repo.mysql.com/apt/ubuntu/ trusty mysql-5.7 

After running apt update and looking at the output of apt-cache policy mysql-server it doesn’t show a candidate for the 5.7 version (only 5.5).

Looking at the repo from a browser http://repo.mysql.com/apt/ubuntu/dists/trusty and navigating the directory I can see that the InRelase and Release files were updated yesterday 07/22/19. Additionally the 5.7 directory has a zero length Packages file. I’m curious if they’ve updated them to remove support for Ubunutu 14.04.