Magento 2.2.5 can’t find sitemap while it is generated

I’m struggling with an weird issue. I can’t make any custom files / folders in my root of magento. I want to make a custom folder with some images, resulating in 404 errors when trying to reach the path of this images.

Also, the generated XML Sitemap throws an 404 error. The path for the sitemap is /sitemaps/sitemap.xml. Magento can’t find this path. Is there a seting i’m overlooking? Because first it worked well.

Hope someone can help me with this!

After Upgrade 2.2.5 to 2.3.0 :product image URL 404

I have upgrade Magento version 2.2.5 to 2.3.0, after upgrade everything working fine but product image URL which is coming from media/catalog/product/cache/ all image URL 404, can anyone help me for this. I have disabled all installed module, also checked in default theme but the issue is not resolving can anyone have an idea how to fix this

Magento 2.2.5: Invalid attribute name: status on bulk edit/import

I am receiving this strange error when trying to bulk update products:

“Invalid attribute name: status”

I assume this is a problem with “Status” which is essentially “Product_online”

The thing is, there are no glaring issues with this attribute. It seems to work fine when fixing something individually, yet with bulk imports/bulk edits on the grid it always throws this error. This error only stops updating certain attributes also. Things like price, URL_key, quantity update fine.

Nothing is appearing in my exception logs, despite throwing an exception.

Any ideas on what could be causing this issue? I’ve found where the exception is thrown in: http/vendor/magento/module-eav/Model/Entity/Collection/AbstractCollection.php at line 1382

Which tells me if the attribute doesn’t exist throw this error. But the attribute DOES exist. This is a fairly new installation of magento and none of the core files have been edited.

I may be missing something completely obvious, but any help would be appreciated.

Thanks

Magento 2.2.5 The itemprop attribute was specified, but the element is not a property of any item

Does anyone have any idea what I need to add in order to solve the issues for the following piece of code?:

<div class="product-info-main">     <div class="product attribute overview">         <div class="value" itemprop="description">             KISS KISS BANG BANG         </div>     </div>     <div class="product-info-price">         <div class="page-title-wrapper product">             <h1 class="page-title"><span class="base" data-ui-id="page-title-wrapper" itemprop="name">FAUX FUR TEDDY COAT</span></h1>         </div>         <div class="price-box price-final_price" data-price-box="product-id-9586" data-product-id="9586" data-role="priceBox">             <span class="normal-price"><span class="price-container price-final_price tax weee" itemprop="offers" itemscope itemtype="http://schema.org/Offer"><span class="price-wrapper" data-price-amount="350" data-price-type="finalPrice" id="product-price-9586"><span class="price">€350.00</span></span></span></span>             <meta content="350" itemprop="price">             <meta content="EUR" itemprop="priceCurrency">         </div>     </div> </div> 

The errors are for the following pieces of code:

<div class="value" itemprop="description">KISS K...  <span class="base" data-ui-id="page-title-wrapper" itemprop="name">...  <span class="price-container price-final_price tax weee" itemprop="offers" itemscope itemtype="http://schema.org/Offer">...  <meta itemprop="price" content="350" />...      <meta itemprop="priceCurrency" content="EUR" />... 

catalog_category_product_index table empty (Magento 2.2.5)

Our indexer re-fills the table catalog_category_product_index_store1, but the table catalog_category_product_index remains empty.

I have found this issue https://github.com/Smile-SA/elasticsuite/issues/991 , but even after an upgrade of the smile/elasticsuite module to 2.5.13, the table remains empty.

In some of our development environments, the table is filled. But when I truncate it and reindex, it stays empty.

This is how I reindex:

bin/magento indexer:reindex catalog_product_category 

Any ideas?