Installing mono on ubuntu: mono-devel : Depends: libglib2.0-0 (>= 2.56.3) but 2.56.1-2ubuntu1 is to be installed

I’m following https://www.mono-project.com/download/stable/#download-lin-ubuntu to install mono on ubuntu. However in the last step I get

sudo apt install mono-devel Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:  The following packages have unmet dependencies:  mono-devel : Depends: libglib2.0-0 (>= 2.56.3) but 2.56.1-2ubuntu1 is to be installed               Recommends: mono-csharp-shell but it is not going to be installed               Recommends: referenceassemblies-pcl but it is not going to be installed               Recommends: msbuild but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

My Ubuntu is indeed 18.04. What should I do?