NodeJS not compatible

when I run gulp serve I get the following error.

Your dev environment is running NodeJS version v10.15.0 which does not meet the requirements for running this tool. This tool requires a version of NodeJS that matches >=8.9.4 <9.0.0

My current version of

 - Node is 10.15  - Gulp is 3.9  - @Microsoft/sp-core-library -1.7.1 

I followed this article but it works only for Microsoft framework 1.2.0 but it does not work for Microsoft framework 1.6.0 or Microsoft 1.7.1

When I follow the above article I can run gulp serve but I cannot include the

import { AadHttpClient, HttpClientResponse } from '@microsoft/sp-http'; 

as it is only supported in spfx framework 1.6 and above.

Is there a way to get the workbench working.

Is AppFabric 1.1 compatible with Windows Server 2016?

So I am trying to install Sharepoint Server 2019 on a box with Windows Server 2016 that is not connected to the Internet.

You can see the software and hardware requirements here:

Ok, so it requires Microsoft AppFabric 1.1 for Windows Server.

But apparently Microsoft AppFabric 1.1 can’t be installed on Windows Server 2016: (Look at supported operating systems)


I downloaded WindowsServerAppFabricSetup_x64.exe from that link, and the installer wouldn’t run. Is there some other link that I should download it from?

How compatible are data science notebooks with clean architecture?

Clean architecture decouples an app’s core from the presentation/UI layer. The UI is just a plugin, replaceable (eg, web-based to desktop) without impacting the core.

Many data science apps mix code, user inputs, text, graphics and other outputs in one notebook, eg, Jupyter. Everything seems coupled: the domain, UI, presentation, persistence.

Q: How to design such an app cleanly, with the notebook maximally decoupled? Or are notebooks inherently incompatible with clean architecture?

Perhaps I could have an independent module with core functionality. The notebook would call this module, without defining any non-trivial functionality. Would this, however, allow enough decoupling or even fit with a notebook?


I’ll be developing an app for a client who’s only used Excel. The app will predict cost effectiveness of medical treatments and will need MCMC simulations, regression and other stats.

I plan to implement it in Python with Jupyter or the nteract notebook, pushed by Netflix However, this may eventually prove unsuitable for the client, as Jupyter is mainly used by those who program it themselves. There’re other potential pitfalls, eg, Ideally, I could easily swap between notebook types or change over to a desktop GUI.

TensorFlow-GPU-Fighting compatible versions for Udacity Deep learning tutorial

I’m having a compile issue, the code I’m executing is from Udacity’s deep learning tutorial assignment #4. This leads me to believe that the problem does not lie within the code but within the software tools that I’m using. I didn’t have any issues with the previous 3 assignments, but now I’m using TensorFlow conv2d member. My system details and error output are listed below. Any help would be greatly appreciated if you need the code, let me know and I’ll post it.

System Details: System: Windows 10 home 64-bit, x64-based processor Cuda: v 9.0.176 CUDNN: v 9.0 win10x64 tf-gpu: v 1.5.0 via PIP NVIDIA: GTX 1060 6 GiB NVIDIA DRIVER VERSION: 417.35 python v: 3.6.7

Output: ~\Documents\Udacity\Deep Learning\Assignment 4 (CNN’s)> python Training set (200000, 28, 28) (200000,) Validation set (10000, 28, 28) (10000,) Test set (10000, 28, 28) (10000,) Training set (200000, 28, 28, 1) (200000, 10) Validation set (10000, 28, 28, 1) (10000, 10) Test set (10000, 28, 28, 1) (10000, 10) 2019-01-04 15:40:09.714793: I C:\tf_jenkins\workspace\rel-win\M\windows-gpu\PY\tensorflow\core\platform\] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX AVX2 2019-01-04 15:40:10.003545: I C:\tf_jenkins\workspace\rel-win\M\windows-gpu\PY\tensorflow\core\common_runtime\gpu\] Found device 0 with properties: name: GeForce GTX 1060 major: 6 minor: 1 memoryClockRate(GHz): 1.6705 pciBusID: 0000:01:00.0 totalMemory: 6.00GiB freeMemory: 4.97GiB 2019-01-04 15:40:10.013346: I C:\tf_jenkins\workspace\rel-win\M\windows-gpu\PY\tensorflow\core\common_runtime\gpu\] Creating TensorFlow device (/device:GPU:0) -> (device: 0, name: GeForce GTX 1060, pci bus id: 0000:01:00.0, compute capability: 6.1) Initialized 2019-01-04 15:40:12.584016: E C:\tf_jenkins\workspace\rel-win\M\windows-gpu\PY\tensorflow\stream_executor\cuda\] Loaded runtime CuDNN library: 7301 (compatibility version 7300) but source was compiled with 7003 (compatibility version 7000). If using a binary install, upgrade your CuDNN library to match. If building from sources, make sure the library loaded at runtime matches a compatible version specified during compile configuration. 2019-01-04 15:40:12.601433: F C:\tf_jenkins\workspace\rel-win\M\windows-gpu\PY\tensorflow\core\kernels\] Check failed: stream->parent()->GetConvolveAlgorithms( conv_parameters.ShouldIncludeWinogradNonfusedAlgo(), &algorithms)

Writing code compatible with BOTH Ruby and Crystal

I know both languages are syntactically similar so i’m a little interested in using both in the same source file. Right now, unfortunately, I only have an Android phone with Ruby installed in Termux. Sadly Termux doesn’t have a Crystal compiler with the neccessary modifications in it’s repositories so I can ONLY run it as Ruby code but I fully intend to compile this later and I’d prefer to write a little boilerplate code in order to make it run on both rather than rewrite parts of it later!

In order to write code compatible with both Ruby and Crystal:

  1. First off, is this even possible with complex apps?
  2. What features in either language have to be avoided?
  3. Will error handling features similar to Python’s try/except allow trying e.g. Ruby way first, else try Crystal way without raising errors in either lang?
  4. Will the different file extensions cause problems or will command line args be enough to rectify this?

Is a different sub version of Media encoder compatible with After effects?

I tried to use Media encoder 2015.3 with After effects 2015.0 but I got errors when tried to use dynamic link. I got error that Media encoder is not installed. Similarly, when tried to access .ae file from Media encoder, it said After effects is not installed.

Now, if I understand correctly, we can’t use v2015 with v2016. But can we use if main version is same but sub version is different? For example, can I use Ae 2019.16 with Media encoder 2019.13?

Magento 2.3 upgrade breaks HTTP POST requests to custom module endpoint – Is there a backwards compatible solution?

this topic shows a solution for the broken POST requests due to Magento 2.3 upgrade. However the solution is breaking the compatibility of my module with Magento <2.3 shops.

Can anyone think of a workaround to support older versions as well?

Streaming camera compatible with Canon lenses

I have just received my Elgato Cam Link 4K. I wanted to use it to convert my DSLR to high-quality webcam for video conferences. I have Canon EOS 80D, and unfortunately, there are 2 problems with it: it is not outputting FullHD signal and there is no way to turn off autofocus box from the signal. I have to use it with manual focus, and I often go outside focus range.

I’m wondering what is the best value for money purchase to have a camera that will be compatible with Canon EF-S, EF lenses and will output plain signal via HDMI with at least FullHD res with continuous autofocus possibility. My research leads me to Canon EOS-R, I think there has to be a cheaper alternative.