How to fix ‘Inconsistencies in the existing project dependencies found’

I am adding AdView in my Android Studio project but when pressing the download/add button of the AdView, this error message pops up:

‘This operation requires the library com.google.android.gms:play-services-ads:+.

Problem: Inconsistencies in the existing project dependencies found. Version incompatibility between: – androidx.activity:activity:1.0.0-alpha08@aar and: – androidx.concurrent:concurrent-futures:1.0.0-beta01@jar

With the dependency: – com.google.guava:listenablefuture:[1.1.0-beta01,1.1.1) versus: – com.google.guava:listenablefuture:[1.0,1.0.1)

The project may not compile after adding this library. Would you like to add it anyway?’

Here’s my gradle dependencies:

 dependencies {  implementation fileTree(dir: 'libs', include: ['*.jar'])  implementation 'androidx.appcompat:appcompat:1.0.2'  implementation 'com.google.android.material:material:1.0.0'  implementation 'androidx.constraintlayout:constraintlayout:1.1.3'  testImplementation 'junit:junit:4.12'  androidTestImplementation 'androidx.test:runner:1.2.0'  androidTestImplementation 'androidx.test.espresso:espresso-core:3.2.0'  implementation 'androidx.gridlayout:gridlayout:1.0.0'  implementation 'androidx.recyclerview:recyclerview:1.0.0'  implementation 'com.squareup.picasso:picasso:2.5.2'  implementation 'com.google.android.material:material:1.1.0-alpha07'   } 

E: Unmet dependencies. Try ‘apt –fix-broken install’ with no packages (or specify a solution)

So, I’ve just boot up my Linux Mint 19.1. Haven’t done it in 3 months or so and of course I had a lot of updates to go through. So I fired up my update manager and it went crazy: downloading, unpacking, installing.. all that good stuff. until I got and error:

You have 1 broken package on your system! Use the "Broken" filter to locate it. 

And now it doesn’t work.

I’ve went to the command line and typed sudo apt-get update and this is what I got back:

Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease                                                                             Hit:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                                                                                              Hit:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease                                                                                            Hit:5 http://archive.canonical.com/ubuntu bionic InRelease                                     Ign:6 http://packages.linuxmint.com tessa InRelease                       Hit:7 http://packages.linuxmint.com tessa Release   Reading package lists... Done  

It doesn’t seem like it installed… Then I typed sudo apt-get upgrade and this is what I get:

Reading package lists... Done Building dependency tree        Reading state information... Done You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies:  libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.24.2-0ubuntu0.18.04.1) but 2.22.4-0ubuntu0.18.04.1 is installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). 

I, obviously, typed in 'apt --fix-broken install' and nothing happens:

apt Usage: apt command [options]        apt help command [options]  Commands:   add-repository   - Add entries to apt sources.list   autoclean        - Erase old downloaded archive files   autoremove       - Remove automatically all unused packages   build            - Build binary or source packages from sources   build-dep        - Configure build-dependencies for source packages   changelog        - View a package's changelog   check            - Verify that there are no broken dependencies   clean            - Erase downloaded archive files   contains         - List packages containing a file   content          - List files contained in a package   deb              - Install a .deb package   depends          - Show raw dependency information for a package   dist-upgrade     - Upgrade the system by removing/installing/upgrading packages   download         - Download the .deb file for a package   edit-sources     - Edit /etc/apt/sources.list with your preferred text editor   dselect-upgrade  - Follow dselect selections   full-upgrade     - Same as 'dist-upgrade'   held             - List all held packages   help             - Show help for a command   hold             - Hold a package   install          - Install/upgrade packages   list             - List packages based on package names   policy           - Show policy settings   purge            - Remove packages and their configuration files   recommends       - List missing recommended packages for a particular package   rdepends         - Show reverse dependency information for a package   reinstall        - Download and (possibly) reinstall a currently installed package   remove           - Remove packages   search           - Search for a package by name and/or expression   show             - Display detailed information about a package   showhold         - Same as 'held'   source           - Download source archives   sources          - Same as 'edit-sources'   unhold           - Unhold a package   update           - Download lists of new/upgradable packages   upgrade          - Perform a safe upgrade   version          - Show the installed version of a package 

Sooo… does anybody has any idea what happened and how can I fix this ? Because I don’t.

How do I break down a feature that has complex dependencies?

Picture this feature:

Respond to a user from the event stream

The event stream is like Twitter’s home page, a stream of messages or events that were triggered by any number of users. The feature is to build a reply feature to one of the messages. Think the ability to reply to a tweet from the your personalised homepage on Twitter.

So in my eyes, this project has many facets:

  1. Frontend Modal Window to Trigger the Event
  2. Permissions to discern whether or not a user can reply
  3. Backend endpoint for submission of reply
  4. Connection to our notification system to tell the message’s user that they have a reply
  5. Validation to ensure the reply meets our criteria

How do we break this down? It seems simple, I take those 5 tasks, and I change them into user stories or tasks (whichever is appropriate).

However, in Scrum, using INVEST principles, each story should be at the very least releasable and independent. However, in this case, I cannot do the validation until the backend endpoint and the frontend modal window has been completed, so this fails the test of being independent and releasable. Furthermore, I cannot react to permissions issues until the frontend work has been done, and this would also impact the backend endpoint. Included within this, is the fact that we need the database schema (and the model) for the replies, which acts as a dependency for the entire project.

I’m struggling to adhere to Scrum and INVEST when speccing projects because of how tightly dependent they all are on each other. It’s specifically the ability to make them independent and releasable that I just can’t seem to fathom. Can someone help?

How do I block a package’s dependencies from explicit apt-get remove?

I need to use

sudo apt-get -y --purge remove $  manypackages 

where $ manypackages includes dependencies of a package that I don’t want removed.

Is it possible to prevent apt-get from removing those dependencies instead of me having to determine them and remove them from the $ manypackages list beforehand?

Adding an ordered into a relationship without violating the functional dependencies

Assuming that we have the relationship $ R(A,B,C,D)$ , the tuple $ (W,X,Y,NULL)$ and the following functional dependencies:

$ $ A \to C$ $ $ $ A \to B,D$ $

is it possible to insert a tuple with $ NULL$ values, without violating the functional dependencies? I understand the definition of functional dependencies but I’ve never actually thought about what would happen for $ NULL$ values. On the one hand, if you consider $ NULL$ as a value then yes but if you say that it’s the absence of value, then you can’t. But in the case of the possibility of adding the tuple, mentioned above, without violating the functional dependencies, what could you do?

Mint19 : KDE installation, missing dependencies

I am trying to install Kubuntu desktop on Linux mint-19, but failing with following error. How can I fix it? I have tried install -f, adding kubuntu PPA, but nothing helps.

Error log :

sudo apt-get install kubuntu-desktop Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:  The following packages have unmet dependencies:  kubuntu-desktop : Depends: software-properties-kde but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

Official sources.list :

# Do not edit this file manually, use Software Sources instead.  deb http://packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main  deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse  deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse deb http://archive.canonical.com/ubuntu/ bionic partner official-package-repositories.list (END) 

Software build processes – Dependencies without admin privileges

we have the following problem and I would like to hear your opinions for this case:

Currently several users are working with domain accounts which are in the local admin group (Yes, shame…)

You need this for build processes, because you have to work on certificates in the user store (with private keys, not exportable) as well as the Windows Credential Store. Additionaly there is a need to move certificates.

Now the environment should be made more secure and the domain accounts should be removed from the admin group. The users should get a local admin account to be able to use it for starting the application in the admin context.

Now the users have no possibility to access the user store (certificates and credential store), because the application runs in a different user context.

According to the people it means a considerable additional effort to adapt the build processes. Furthermore, the storage of certificates in the machine store is not considered safe.

What is your opinion? Can this be solved in a smart way?

Find candidate keys given functional dependencies

In my database class we practiced how to find the candidate keys, given the functional dependencies. However they were easy examples, based on a single attribute being functionally dependent on a single attribute but in our book it gives the following example of more complex functional dependencies. Let’s say that I have the following relationship:

$ $ R(A,B,C,D,E,F)$ $

with the following functional dependencies:

$ $ f_1: \{A,B,C\} \to \{D,F\}$ $ $ $ f_2: \{D,E,F\} \to \{A,C,E\}$ $ $ $ f_3: \{D\} \to \{B\}$ $

and I need to find all the candidate keys. Because we need at least $ 3$ of the attributes to make candidate keys. Through writing out each of the tuples made up of $ 3$ or more attributes, I found that $ \{A, D,E,F\}$ , $ \{A,B,C,E\}$ , $ \{D,E,F\}$ and $ \{A,C,D,E\}$ are all candidate keys. However the catch is that either $ \{A, D,E,F\}$ , $ \{A,B,C,E\}$ or $ \{D,E,F\}$ ,$ \{A,C,D,E\}$ , $ \{A,B,C,E\}$ are the candidate keys.

I think that because the definition of a candidate key is that there can’t be a subset of it that’s also a candidate key. Using this logic, $ \{A, D,E,F\}$ would also not be candidate key as $ \{D,E,F\}$ is already a candidate key. Therefore, the final candidate keys would be:

$ $ \{D,E,F\},\{A,C,D,E\}, \{A,B,C,E\}$ $

Is my understanding of the topic correct or have I gone of the rails?

How to find highest normal form of a relation, given its functional dependencies

Let’s say that I have a relational model, defined as:

$ $ X(A,B,C,D,E,F,G)$ $ with the functional dependencies: $ $ f_1: \{A,B,C\} \to \{D,E,F,G\}$ $ $ $ f_2: \{A,B\} \to \{C\}$ $

Using this information I need to determine the highest normal form (for us it’s BCNF) that this relation will go to. It’s clear that the relation is already in it’s atomic form, therefore it’s already in it’s first normal form. The to proceed to the second normal form, I found that the candidate key is $ \{A,B\}$ and since all non prime attributes are fully dependent on the candidate keys, it’s in the second normal form. But from this point I’m not sure where to go because all the non prime attributes (excluding $ C$ ), $ D,E,F,G$ are dependent on $ C$ which is also a non prime attribute.

How can I separate this relation and proceed to the third normal form?

PS – I’m not sure if this is the right place to ask a database question but since the stack exchange for database is for professionals, I thought I should post it here. If someone knows a better stack exchange for this sort of a question, I’ll transfer it over to that one.

How to remove package libboost-system1.58.0? currently have unmet dependencies

I have boost libary 1.58 installed from default repository and an older version installed from source. Now I wanna remove the boost 1.58.

First I did was to remove the libboost-all-dev package, but there are still four packages left installed, two of which i remove seperately, and two I just cannot remove. These two packages are: libboost-system1.58.0 and libboost-filesystem1.58.0. Whenever i do sudo apt-get --purge remove libboost-system1.58.0 there are unment dependencies errors, which relates to qt, which I have no idea why it has anything to do with.

The error output looks like this:

The following packages have unmet dependencies:  liboxideqt-qmlplugin : Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                  libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  liboxideqtcore0 : Depends: libqt5gui5 (>= 5.4.0) but it is not going to be installed or                             libqt5gui5-gles (>= 5.4.0) but it is not going to be installed  liboxideqtquick0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                              libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                     Depends: libqt5quick5 (>= 5.2.0) but it is not going to be installed or                              libqt5quick5-gles (>= 5.2.0) but it is not going to be installed  libqmenumodel0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                            libqt5gui5-gles (>= 5.0.2) but it is not going to be installed  libqt5multimedia5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed or                               libqt5gui5-gles (>= 5.2.0) but it is not going to be installed  libqt5multimediaquick-p5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                      libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                             Depends: libqt5quick5 (>= 5.4.0) but it is not going to be installed or                                      libqt5quick5-gles (>= 5.4.0) but it is not going to be installed  libqt5x11extras5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                              libqt5gui5-gles (>= 5.0.2) but it is not going to be installed  libubuntugestures5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                       Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  libubuntutoolkit5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                               libqt5gui5-gles (>= 5.0.2) but it is not going to be installed  qml-module-io-thp-pyotherside : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                           libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                                  Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                           libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  qml-module-qtquick-layouts : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or                                        libqt5gui5-gles (>= 5.5.0) but it is not going to be installed                               Depends: libqt5quick5 (>= 5.2.0) but it is not going to be installed or                                        libqt5quick5-gles (>= 5.2.0) but it is not going to be installed  qml-module-ubuntu-layouts : Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                       libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  qml-module-ubuntu-performancemetrics : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                                  libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                                         Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                                  libqt5quick5-gles (>= 5.0.2) but it is not going to be installed 

My first question is, why is this package libboost-system1.58.0 has anything to do with qt? I looked up in the ubuntu package page, neither these qt packages depend on libboost-system1.58.0 nor does libboost-system1.58.0 depends on these qt packages.

My second question is, is this package libboost-system1.58.0 really relevant? I remember i installed boost with apt-get install libboost-all-dev, but apparently libboost-system1.58.0 is not in the dependecy list to libboost-all-dev. So where does this package come from?

Third question might not be related to this problem, but I looked through these qt packages, when I check them, I saw they all have duplicate packages with different versions, for example:

liboxideqtcore0/xenial-updates,xenial-security,now 1.21.5-0ubuntu0.16.04.1 amd64 [installed,automatic] liboxideqtcore0/xenial 1.13.6-0ubuntu1 amd64 

So does this relate to my problem here?

Thanks a lot to you guys in advance BG