Parse error: syntax error, unexpected ‘private’ (T_PRIVATE), expecting end of file in C:\xampp\htdocs\proyecto\php\conexion.php on line 3

lo que sucede es que cuando trato de ingresar o registrarme me aparece esto: Parse error: syntax error, unexpected ‘private’ (T_PRIVATE), expecting end of file in C:\xampp\htdocs\proyecto\php\conexion.php on line 3

este es mi código:

      <?php  private $  servidor="localhost"; private $  usuario="root"; private $  password=""; private $  bd_usu="limpieza_es";  ?>           <div class="contenido">         <h3>FORMULARIO DE  REGISTRO</h3>          <div class="form-group">             <label for="nombre">Nombre:</label>             <input type="text"  name="nombre" class="form-control" id="nombre" required autofocus/>             <label for="apellido">Apellido:</label>             <input type="text" name="apellido" class="form-control" id="apellido" require/>             <label for="email">Email:</label>             <input type="text" name="email"  class="form-control" id="email" require/>             <label for="tel">Telefono:</label>             <input type="text" name="tel" class="form-control" id="tel" require/>             <label for="con">Contraseña:</label>             <input type="password" name="con" class="form-control" id="con" require/>             <br>             <button type="submit" class="btn btn-primary mb-2">Registrar</button>          </div>           </form>    </div>    </div>       

Agradezco su colaboración…

PHP Parse error: syntax error, unexpected ” (T_ENCAPSED_AND_WHITESPACE), expecting ‘-‘ or identifier (T_STRING) or variable (T_VARIABLE) or number

Buen día. Tengo un problema,me sucede que al tratar de realizar esta consulta de MySQL en PHP me sale este error:

PHP Parse error: syntax error, unexpected ” (T_ENCAPSED_AND_WHITESPACE), expecting ‘-‘ or identifier (T_STRING) or variable (T_VARIABLE) or number (T_NUM_STRING)

Aquí mi código:

require 'Smarty/libs/Smarty.class.php';     require 'conexion.php';      $  smarty = new Smarty;      $  upd=("SELECT * FROM RegistroPromedio WHERE Id LIKE ".$  _POST['Id']."");       $  dato=mysqli_fetch_array($  upd);              if (isset($  _POST['submit'])) {             $  qry=("UPDATE RegistroPromedio SET                  nombre='.$  _POST['nombre'].'                 ,apellido='.$  _POST['apellido'].'                 ,edad='.$  _POST['edad'].'                 ,TipoId='.$  _POST['TipoId'].                 ,Id='.$  _POST['Id'].'                 ,salario='.$  _POST['salario'].'");          header('Location:index.php');      } var_dump($  qry);       $  smarty->assign('users',$  dato);     $  smarty->display("templates/edit.html"); 

Agradezco si me pueden ayudar.

If someone casts Charm Person or a similar spell on somebody who’s expecting it, what happens?

Say somebody says “I’m going to use a spell to charm you, and make you walk around the room,” for a bet or something. You know it’s coming, you know your goals, but what effect does this have on saving throws? What does the charm do to your thought process? Might you have advantage on the saving throw if you’re mentally prepared? Or does it simply mean that while charmed you still might not do as they say? How does this apply to more powerful charms?

Magento 2.2.9 Parse error: syntax error, unexpected ‘?’, expecting variable (T_VARIABLE) magento setup:upgade command

I received the error when I try to run

php bin/magento setup:upgrade

after i did

composer require magento/product-community-edition 2.2.9 –no-update

composer update

for updating from magento 2.2.6. to 2.2.9 (which went fine)

error message is ......... Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE)...../interceptor.php 

magento version is 2.2.7 – > 2.2.9

php version is 70.033

I have searched and found a few answers, but all applied to 2.3.x version, which required high php versions (7.1 or 7.2). so i also tried the following command

php72 bin/magento setup:upgrade

which came out with another error..

Seeing ‘AttributeError: __enter__ ‘when expecting to see Rasa Bot responses

I am trying to follow a post over creating and running a Rasa bot

Steps already did: – I could get all working folders – Got the basic data files – Trained Nlu and Core – launched action server and command line – So here the expectation is User enters Input like ‘Hi or hello’ and then bot responds and continues the chat

Actual results: Seeing below error.

make cmdline python -m rasa_core.run -d models/current/dialogue -u models/current/nlu --endpoints endpoints.yml C:\Python3.6\lib\site-packages\h5py\__init__.py:36: FutureWarning: Conversion of the second argument of issubdtype from `float` to `np.floating` is deprecated. In future, it will be treated as `np.float64 == np.dtype(float).type`.   from ._conv import register_converters as _register_converters 2019-05-14 17:06:45 INFO     root  - Rasa process starting 2019-05-14 17:06:49 INFO     rasa_nlu.components  - Added 'nlp_spacy' to component cache. Key 'nlp_spacy-en'. 2019-05-14 17:07:18.101829: I tensorflow/core/platform/cpu_feature_guard.cc:141] Your CPU supports instructions that this TensorFlow binary was not compiled to use: AVX2 2019-05-14 17:07:19 INFO     root  - Rasa Core server is up and running on http://localhost:5005 Bot loaded. Type a message and press enter (use '/stop' to exit): Your input ->  hey 127.0.0.1 - - [2019-05-14 17:08:23] "POST /webhooks/rest/webhook?stream=true&token= HTTP/1.1" 200 190 0.254340 Exception in thread Thread-1: Traceback (most recent call last):   File "C:\Python3.6\lib\threading.py", line 916, in _bootstrap_inner     self.run()   File "C:\Python3.6\lib\threading.py", line 864, in run     self._target(*self._args, **self._kwargs)   File "C:\Python3.6\lib\site-packages\rasa_core\channels\console.py", line 114, in record_messages     for response in bot_responses:   File "C:\Python3.6\lib\site-packages\rasa_core\channels\console.py", line 71, in send_message_receive_stream     with requests.post(url, json=payload, stream=True) as r: AttributeError: __enter__  

On preliminary search over forums, seems it is a Python code issue, as I understand it try to get bot responses using ‘WITH’ keyword ?

Any pointers on how can I get it sorted please ? Thanks in advance, Venky