SharePoint Web application giving 404 not found error

I have 2 web applications (Main site and My site) and both were running perfectly on port 80. Since debugging was not working even after attaching to the worker process, I tried to reset Visual Studio settings using command line tool. After that my web applications were not loading. Even if I try to access from IIS, it’s showing 404 Not found error. I don’t know whether it’s because of Visual studio settings reset or not. After IIS RESET / Application Pool reset also still I am getting the same error.

I have 1 wfe and 1 ap server. I tried to create new web apllication, that also only accesible from AP server only, not from WFE server.

Can anyone please help me.

If Statement Giving Wrong Output Issue Calculated Column

I have this simple if statement where there are two columns. Column 1 = Score Column 2 = Test

This is the If Statement Code:

=IF([Score]>70,"A","F") 

If the score is greater than 70 it should give an A in the Test Column. If it’s less than 70 it’s F.

The picture below is the issue. Am I doing something wrong here?

enter image description here

GRUB is giving an error while loading Windows 10

I’m getting an error while loading Windows 10 from GRUB menu. Ubuntu loads perfectly fine. And I can load Windows from boot menu tho, but that isn’t always a feasible option. I want my grub menu to work for both OS. I did a fresh installation of both OS on my lenovo G50-45 laptop.

Points to consider:
• Installed Windows 10 on 120 SSD.
• Installed Ubuntu 19.04 on 500GB HDD.
• Both drives are GPT partitioned and boots in UEFI.
• I disabled secureboot in BIOS, and fastboot, hibernation in Windows 10.
• I tried updating grub using “sudo update-grub”, where it detects the windows boot manager in the drive (/dev/sdb2) and I think it updates too, but it isn’t helping.

Here is how my disks are partitioned:

SDA (500GB HDD)
sda1 | 350MB | /boot/efi
sda2 | 30GB | /
sda3 | 8GB | [SWAP]
sda4 | 50GB | /home

SDB (120GB SSD)
sdb1 | 529MB | Microsoft Windows Recovery Environment
sdb2 | 100MB | EFI system
sdb3 | 16MB | Microsoft Reserved
sdb4 | 111GB | System files.

This is how my grub menu looks like

Ubuntu
Advanced Options for Ubuntu
Windows Boot Manager (on /dev/sdb2)
System Setup

After selecting “Windows Boot Manager (on /dev/sdb2)”, instead of loading Windows 10, this is the error I get

error: no such device : 3C3C B62B.
error: disk ‘hd1,gp2’ not found.
Press any key to continue…

After pressing any key, it brings me back to the grub menu

While on grub menu,and after pressing ‘e’ for editing windows boot entry, this is what I get

setparams 'Windows Boot Manager (on /dev/sdb2)'           insmod part_gpt         insmod fat         set root = 'hd1,gpt2'         if [x$  feature_platform_search_hint=xy]; then             search --no-floppy --fs-uuid --set-root --hint-bios=hd1,gpt2 --hint-efi=hd1,gpt2 --hint-baremetal=ahcil,gpt2 3C3C-B62B         else             search --no-floppy --fs-uuid --set-root 3C3C-B62B         fi         chainloader /efi/Microsoft/Boot/bootmgfw.efi 

One thing I have observed is that, after changing boot priority to Windows drive, and again back to Ubuntu drive, the grub menu loads Windows successfully, but only once. The story repeats here after.

Can someone please help me solve this problem?

ClientContext giving 403 Forbidden error

I am hosting my site in Azure

Azure and Office 365 have same account detail. But when I am using the following code it’s giving 403 error.

Also while accessing Azure site I already logged in Office 365 then also not able to take ClientContext. As I am aware i’ts SSO by Azure & Office 365.

 try  {      var siteUrl = "https://Office365Site";      using (var clientContext = new ClientContext(siteUrl))      {          clientContext.Load(clientContext.Web, web => web.Title);          clientContext.ExecuteQuery();          Response.Write(clientContext.Web.Title);       }  }  catch (Exception ex)  {      Response.Write(ex.Message);  } 

Please help in this issue.

Giving one of two options

I am really new to all of this, but I’m trying to edit a column with the following:

=OR(LEFT([Ticket Number],6) ="TASK00",LEN([Ticket Number])=0) 

where the user is required to enter their ticket number as “TASK00XXXXX” where X is the number of the ticket. I would like to adjust this to limit them to both TASK00 and RITM00 but I’m not having much luck. Any help is much appreciated!

SQL JOIN giving doubled values

I am trying to display a total quantity of products, their weight and price. The results come from 4 different tables.

When I do this without join then I get proper values but when I use Join then I get double values on all outputs.

Without join I can’t achieve this as these results need to be all in one table.

I tried not using Join and just including those tables in ‘FROM’ but that thrown me errors about issues converting to numeric. I also tried Union but didn’t work.

When using no join and not trying to display all the values, I get the desired output but with missing columns that I missed out on purpose to test this.

SELECT PriceListTest.Description, COUNT(ItemCode) AS Quantity,    SUM(Weight) AS 'Weight', Item.Pieces, PriceListTest.Price,     CAST(SUM( PriceListTest.Price * Weight) as    DECIMAL(10,2)) as 'Unit Price', CAST(SUM(PriceListTest.Price * Weight) as    DECIMAL(10,2))   AS 'Nett Amount'   FROM StockItems    INNER JOIN PriceListTest ON   StockItems.ItemCode = PriceListTest.Description   INNER JOIN Item ON StockItems.ItemCode = Item.ShortCode    WHERE Barcode IN (SELECT DISTINCT Barcode FROM StockOuttbl    WHERE ContainedID = 'isr5063' AND Status ='' GROUP BY Barcode) AND    PriceListTest.CustomerID = (SELECT DISTINCT CustomerID From Customerstbl    WHERE CustomerID ='1')   GROUP BY PriceListTest.Description, Item.Pieces, PriceListTest.Price; 

Status in this case is empty, so that’s not the issue

I getting these values:

Description Quantity    Weight  Pieces  Price   Unit Price  Nett Amount Product1        52        20242 0       1.23        24897.66    24897.66   Product2        50        17206 0       1.23        21163.38    21163.38 

This is the output I am looking:

Description Quantity    Weight  Pieces  Price   Unit Price  Nett Amount Product1        26          10121   0   1.23    12448.83‬   12448.83                                                                ‬ Product2        25          8603    0   1.23    10581.69    10581.69  

When I don’t use the PriceListTest in Join then I don’t get the doubles, but then it’s not exactly what I am looking for.

I get:

Description Quantity    Weight  Pieces Product1        26      10121   0          Product2        25       8603   0    

I’d appreciate any help with this. Thanks in advance!

Would giving Sorcerer archetypes extra “spells known” unbalance them?

Sorcerers don’t have many spells. If I compare them to other full casters (I’m not including Warlocks in this because they work entirely differently), namely Bards, Clerics, Druids and Wizards, then they seem to come up short.

By level 20:

  • Bards know 22 spells;
  • Clerics/Druids can have between 24-25 spells prepared (assuming WIS of 18-20);
  • Wizards know a whopping 44 spells (only including spells gained via levelling) but can only prepare about 25, as per Cleric/Druid;
  • Sorcerers only know 15;

Sorcerers are the clear losers here. Not that I expect them to have as many as Wizards (since that’s their thing), but 15 just seems way too few to me, and I don’t think that Metamagic alone makes up that difference (which is all they seem to have besides spells). So I was thinking of giving them a free (but specific) spell between spell levels 1st-5th, much the same as I did for the PHB Rangers.

This way, the Sorcerer would know 20 spells; still fewer than everyone else, but not by as great-a-margin. As with my other question, the spells I have picked suit their flavour and include spells from within their own spell list and from other spell lists (which would count as sorcerer spells for them), but only one extra spell per spell level (up to 5th). I’m not listing them all here, though, as it would take up too much room (I’ve done this for the UA archetypes, too).

I suppose the player of these “enhanced sorcerers” could potentially swap out the free spell for any old sorcerer spell, effectively giving them 20 total spells without the flavour, but as covered in this question, I’m going to assume they can’t do that, much the same as with the extra Ranger spells (or at the very least, I would rule that they can’t, given that I’d be the DM in this situation, what with it being my homebrew).

So, my question is does the increase in number of spells known impact the strength of the class in a way that might make it preferable to the other spellcasters? I’ve always felt they were the weaker option, but that might just be because I don’t use Metamagic to it’s full potential or something, so will these additional spells and the increased flexibility they provide unbalance anything beyond what I have anticipated?


As a caveat, I’m aware that the XGTE archetypes (and the new Giant Soul Sorcerer archetype from UA, but I don’t care as much about that because it’s just UA, and my main balance concerns are with the official released archetypes) already include an additional spell; namely the Divine Soul’s Divine Magic feature (XGTE, pg. 50):

In addition, choose an affinity for the source of your divine power: good, evil, law, chaos, or neutrality. You learn an additional spell based on that affinity […]

and the Shadow Sorcerer’s Eyes of the Dark feature (XGTE, pg. 51):

When you reach 3rd level in this class, you learn the darkness spell, which doesn’t count against your number of sorcerer spells known.

Therefore, RAW, these Sorcerers would know 16 spells in total by level 20. I’m planning on not giving Divine Soul sorcerers an extra level 1 spell or Shadow Sorcerers and extra 2nd level spell, so that their total is still 20 known spells by the time they hit level 20. I personally don’t think this matters too much since it’s only one spell’s difference, and their class features do provide them with other benefits, so it’s not like I’m taking their class features away from them and giving them to every other sorcerer archetype.

I thought to mention this in case this impacts balance, and therefore any potential answers, in a way I haven’t anticipated; but this is an aside, just some extra information, and my question is not specifically about this aside, but about the impacts of having any sorcerers with 20 spells.

Epson L130 printer giving out blank pages on Ubuntu 18.04

Please consider this as an emergency and help me. I upgraded my system to Ubuntu 18.04 from Ubuntu 14.04. My Epson L130 printer was working fine on 14.04 but even though I added the printer to the 18.04, it doesn’t print documents from Libre Office and other PDF readers. The paper just goes inside, the printer head does some motions but the paper comes out blank. I see that I can print test pages from the internet and from the printer, but no documents can be printed. I tried installing the driver and printer utility from the Epson site. Please suggest some things that I can try out to make it work. Any additional information can be given on demand. Thanks in advance!

Uploading files to sharepoint with clientContext giving Error

I am trying to upload documents to a specified sharepoint location but I am getting the error System.Net.WebException: ‘The remote server returned an error: (400) Bad Request.’

I believe this has something to do with the validation but not 100% on this. Below is my code and the error is returned at the ctx.ExecuteQuery();.

public static void sharepointUpload()         {             String filePath = @"C:\temp\test.pdf";             String siteUrl = "https://<myCompany>.sharepoint.com/";             String documentLibraryName = "PayPoint";             string fileName = filePath.Substring(filePath.LastIndexOf("\") + 1);              string userName = "firstname.surname@companyName.co.uk";             string password = "password";              SecureString securePassword = new SecureString();             foreach (char ch in password.ToCharArray())                 securePassword.AppendChar(ch);             SharePointOnlineCredentials credentials =                     new SharePointOnlineCredentials(userName, securePassword);              using (ClientContext ctx = new ClientContext(siteUrl))             {                 FileCreationInformation fcInfo = new FileCreationInformation();                 fcInfo.Url = fileName;                 fcInfo.Overwrite = true;                 fcInfo.Content = File.ReadAllBytes(filePath);                  ctx.Credentials = credentials;                 Web myWeb = ctx.Web;                 List myLibrary = myWeb.Lists.GetByTitle(documentLibraryName);                 myLibrary.RootFolder.Files.Add(fcInfo);                 ctx.Load(myWeb, w => w.Title);                 ctx.ExecuteQuery();                 Console.WriteLine(myWeb.Title);              }             Console.WriteLine("Succesful Upload");         }