Can you recommend a good budget prime lens for family photos (Canon mount)

I’m very new to photography. Have a Canon T3, with the standard 18-55 lens and a 75-300 mm lens. I’m looking to do a lot of family photography (wife with 2 kids less than 2 years old). Most of the pictures will be indoors, but some will be outside during the day. I was looking at some prime lenses on Amazon, but I’m not sure what would be the best choice – some advice would be appreciated. I’m looking at a budget of $ 100-$ 150 for the lens.

Using longer one line statements according to good practice

Lately I have learned how to use list comprehensions. I’ve started to use them often, but I am not sure how complex one line statements should I write. What is good practice? Could you give me some remarks about code below? It checks if list has only two elements and each of them is int.

a = [3,4] b = ['a',2]  def check_number(number):     return type(number) is int and number >= 0  def check_list(my_list, length):     return type(my_list) is list and len(my_list) == length  def check_segment(segment):     return not bool([True for number in segment if not check_number(number)]) if check_list(segment,2) else False  print(check_segment(a)) print(check_segment(b)) 

1) It seems for me that adding True and False to return could increase readability, but it makes code longer and adds condition check. Is it bad idea?

def check_number(number):     return True if type(number) is int and number >0 else False 

2) Is it too much for one line in return of function check_segment? Should I write it in more traditional way, like:

def check_segment(segment):     if check_list(segment):         result = True         for number in segment:             result = result + check_number(number)         return result     else:         return False 

3) In example up – should I use else when I’m just returning False?

4) Is check_number right name for function which returns boolean according to standards? Should I use is_number_right instead?

5) Is there anything else that should I improve in this code?

Good Evening From Florida

Hello everyone @ Digitalpoint! My Name is Boofy and I am currently living in Florida.

A little about me I am a homemaker with some free time on my hands. Currently looking to fill this free time with a profitable venture. This is why I am here at Digitalpoint!

I have many talents. Hard worker. Great juggler of time. Hope to get to know all of you!

How Can I Convince My Players That This Evil Character Is Good For the Duration Of The Campaign Until The Big Reveal?

My game has a woman who is a noblewoman. Despite her low-status birth and life as a peasant, she would later be seen as a miracle child because of in-world lore related to a physical feature of hers. This allowed her to get many followers who helped push her into the ranks of lower-“nobility” as a baronetess. From there she manipulated her followers in order to make her actions seem more praise-worthy and honorable that she eventually was made a trusted adviser of the king’s, granting her a formal nobility rank as a Countess and, as a result, allowing her to run her criminal operations more smoothly.

Okay, lore aside… She is an absolutely beautiful and cunning woman. She never lies because she doesn’t ever have to thanks to her wording. She has a high charisma and wisdom, so if someone were to question her, she would always be multiple steps ahead of them so that she doesn’t have to say anything that is false. That said, one of her quirks is that she tries to collect (Read: “Enslave”/”Own”) anything that she finds to be unique or valuable and she sets her eyes on one of the PCs.

The PCs just shut down a large part of the kingdom’s slave trade. Slavery isn’t illegal, but it is something the king is trying to edge out of their society. At the same time, he can’t request people to shut down and deincentivise slavers lest he causes unrest in his nobility. He trusts Countess who he does not realize 1) owns many slaves that she keeps hidden in secret and 2) is the one in charge of the vast majority of the kingdom’s slave trade; therefore, the king has invited Countess to the celebration of the PCs shutting down such a large aspect, freeing many slaves and getting them someplace safe. Publicly, the celebration is under the claim that the PCs found a lost artifact (which they do by chance) belonging to the royal family (and therefore the kingdom) by right and it’s to honor their (the PCs’) service to the crown. Everybody who is invited to this celebration are those whom the king trusts with the information relating to the true reason for the party, guests and staff alike.

At the party, Countess will try to seduce one of the PCs by putting a “love potion” of sorts into a drink which she will then offer her target. (I as the DM expect the player to succeed the DC to be unaffected by the immediate effects of the potion, so mentioning the potion is more “side information” than anything.) That said, when they are talking, I need to know how specifically to keep her from coming across as obviously suspicious since she will be directly approaching one of my players and will have a noticeable impact on him thanks to a very “Strahd von Zorovich” style Charm skill while they are talking, regardless of if he drinks from the spiked glass or not.

The problem: My players are quite genre-savvy. When I do this, I expect them to figure out that she is suspicious, if not evil, but I want to avoid her being seen as even suspicious. What is the best way to do this while maintaining the story as intended? This is done through a homebrew system, but if you must, assume D&D’s system. If you need my party’s (the PCs, not the celebration,) information in order to answer this accurately, let me know.

Question: How can I convince my players, not just the characters, that this evil character is actually good for a prolonged length of time until the final reveal?

A best answer will be almost entirely through minimal use of rolls and maximized use of story-telling. Rolling would just add to the suspicion and I don’t want my players to even think they are on to me.

If my tags are inaccurate or inappropriate, please leave a comment suggesting how to improve them.

Is this a good use of Javascript ES6 import / export?

first question here, hope it fits the requirements.

I am experimenting with Javascrip ES6 import and export and wanted to achieve the following :

  • Use the import / export style of including Javascript files.
  • Import a class file and create an instance
  • Import a class file that extends another class
  • Expose functions to the index.html scope – call from an inline onclick event
  • Is document. available within the module scope

Well, it’s appeared I did that. Question = is this the correct, or recommended way of doing this, is there a better way?

Thanks for your input.


<!DOCTYPE html> <html>     <head>         <meta charset="UTF-8">         <title>Javascript - Import and Export class examples</title>     </head>     <body>           <h1>Javascript Import and Export class examples</h1>         <div id="myDiv"></div>         <button onclick="window.updateScreen()">Do it</button>         <script type="module">                       import('./main.js').then(module => {                 /* This function is now available on the button onclick */                 window.updateScreen = module.updateScreen;                           });         </script>     </body> </html> 


import { Animal } from './animal.js'; import { Human } from './human.js'; import { Dog, Cat } from './pets.js';  const petOwner = new Human('Bob', 'Male', '21/03/19'); const pets = [ new Dog('Riley', petOwner), new Cat('Sherry', petOwner) ];  petOwner.speak(); pets[1].speak(); pets[0].speak();  function updateScreen() {     let elem = document.getElementById('myDiv');     elem.textContent = 'HELLO'; }  export { updateScreen }; 


class Animal {     constructor(alive, hr) {         this.isAlive = alive;         this.heartRate = hr;     } } export { Animal }; 


import {Animal} from './animal.js'; class Human extends Animal {     constructor(name, sex, dob) {         super(true, 60); = name;         this.dob = dob; = sex;     }        speak() {         console.log('Hello');        }     get age() {         return now-dob;     } } export { Human }; 


import {Animal} from './animal.js';  class Cat extends Animal {     constructor(name, owner) {         super(true, 200); = name;         this.owner = owner;     }     speak() {         console.log('Meow');         } }  class Dog extends Animal {     constructor(name, owner) {         super(true, 120); = name;         this.owner = owner;     }     speak() {         document.getElementById('myDiv').textContent = 'Woof';       } }  export { Cat, Dog }; 

What is a good preparation for mathematical studies for someone who hasn’t done mathematics in recent years?

To put it simple, I’d like ask for books and other material that I could use to hone my mathematics skills, in preparation for a course at my local university. It’s been a while since I’ve had to use mathematics, so a refresher would be no luxury. Because I was enrolled in a computer science course several years ago, I do have some experience, but I’d really like to fill the gaps that have grown in my knowledge and be as prepared as I can be.

Any references are much appreciated!

Some related questions:

  • Second year mathematics textbook recommendations.
  • Are older mathematics textbooks still “valid”?

Instagram – Whats considered good

So I launched an ecommerce business about 2 months ago and over the past few weeks I have been working on instagram posts with one of my partners "karriermtl".

Do you guys have any tips to improve my account. maybe examples of good instagram accounts I can look at?

I am working on building a following that could potentially drive sales to my business.