I’am running Ubuntu 18.04.2 LTS failed to install samba

noname@star-death-console:~$ apt-get install samba E: Could not open lock file /var/lib/dpkg/lock-frontend – open (13: Permission denied) E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root? noname@star-death-console:~$ su root Password: su: Authentication failure noname@star-death-console:~$ su root Password: root@star-death-console:/home/noname# apt-get install samba Reading package lists… Done Building dependency tree
Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: samba : Depends: python (< 2.8) but it is not going to be installed Depends: python-dnspython but it is not going to be installed Depends: python-samba but it is not going to be installed Depends: samba-common-bin (= 2:4.7.6+dfsg~ubuntu-0ubuntu2) but it is not going to be installed Depends: python (>= 2.7~) but it is not going to be installed Depends: python2.7:any Depends: python:any (< 2.8) Depends: python:any (>= 2.7~) Depends: samba-libs (= 2:4.7.6+dfsg~ubuntu-0ubuntu2) but 2:4.7.6+dfsg~ubuntu-0ubuntu2.6 is to be installed Recommends: attr Recommends: samba-dsdb-modules but it is not going to be installed Recommends: samba-vfs-modules but it is not going to be installed E: Unable to correct problems, you have held broken packages. root@star-death-console:/home/noname#