Porque los carousel en NGX-BOOTSTRAP ocultan el titulo de cada imagen cuando el media queries es para un pantalla pequeña?

Cuando la pantalla es menor que 768px se pierden los textos de titulo y description:

First slide label

Nulla vitae elit libero, a pharetra augue mollis interdum.

Second slide label

Lorem ipsum dolor sit amet, consectetur adipiscing elit.

Third slide label

Praesent commodo cursus magna, vel scelerisque nisl consectetur.

ayuda con carousel de ngx-bootstrap

Estoy trabajando en una aplicacion web con Angular. Estoy intentando hacer funcionar el carousel de ngx-bootstrap, especifcamente el Multilist Start From Index que se encuentra en su pagina pero no logro hacerlo funcionar. Ya instale jquery, bootstrap y ngx-bootstrap a traves de npm e inclui los scripts y css en el angular.json pero cuando copio el codigo de la pagina me lo muestra como aparece en esta foto: introducir la descripción de la imagen aquí y si por ejemplo intento con el primer carousel de la pagina de ngx-bootsrtap me coloca las imagenes extremadamente grandes como se observa aquí: introducir la descripción de la imagen aquí y las imagenes son de resolucion pequeña, no se que es lo que esta pasando sinceramente, ya he intenetado de todo, hasta probe instalar todo nuevamente en una instalacion limpia de Angular y todo sigue igual. Aqui esta mi archivo angular.json: { "$ schema": "./node_modules/@angular/cli/lib/config/schema.json", "version": 1, "newProjectRoot": "projects", "projects": { "seapage": { "root": "", "sourceRoot": "src", "projectType": "application", "prefix": "app", "schematics": {}, "architect": { "build": { "builder": "@angular-devkit/build-angular:browser", "options": { "outputPath": "dist/seapage", "index": "src/index.html", "main": "src/main.ts", "polyfills": "src/polyfills.ts", "tsConfig": "src/tsconfig.app.json", "assets": [ "src/favicon.ico", "src/assets" ], "styles": [ "./node_modules/bootstrap/dist/css/bootstrap.min.css", "src/styles.css", ], "scripts": [ "./node_modules/bootstrap/dist/js/bootstrap.min.js", "./node_modules/jquery/jquery.min.js", ], "es5BrowserSupport": true }, "configurations": { "production": { "fileReplacements": [ { "replace": "src/environments/environment.ts", "with": "src/environments/environment.prod.ts" } ], "optimization": true, "outputHashing": "all", "sourceMap": false, "extractCss": true, "namedChunks": false, "aot": true, "extractLicenses": true, "vendorChunk": false, "buildOptimizer": true, "budgets": [ { "type": "initial", "maximumWarning": "2mb", "maximumError": "5mb" } ] } } }, "serve": { "builder": "@angular-devkit/build-angular:dev-server", "options": { "browserTarget": "seapage:build" }, "configurations": { "production": { "browserTarget": "seapage:build:production" } } }, "extract-i18n": { "builder": "@angular-devkit/build-angular:extract-i18n", "options": { "browserTarget": "seapage:build" } }, "test": { "builder": "@angular-devkit/build-angular:karma", "options": { "main": "src/test.ts", "polyfills": "src/polyfills.ts", "tsConfig": "src/tsconfig.spec.json", "karmaConfig": "src/karma.conf.js", "styles": [ "src/styles.css" ], "scripts": [], "assets": [ "src/favicon.ico", "src/assets" ] } }, "lint": { "builder": "@angular-devkit/build-angular:tslint", "options": { "tsConfig": [ "src/tsconfig.app.json", "src/tsconfig.spec.json" ], "exclude": [ "**/node_modules/**" ] } } } }, "seapage-e2e": { "root": "e2e/", "projectType": "application", "prefix": "", "architect": { "e2e": { "builder": "@angular-devkit/build-angular:protractor", "options": { "protractorConfig": "e2e/protractor.conf.js", "devServerTarget": "seapage:serve" }, "configurations": { "production": { "devServerTarget": "seapage:serve:production" } } }, "lint": { "builder": "@angular-devkit/build-angular:tslint", "options": { "tsConfig": "e2e/tsconfig.e2e.json", "exclude": [ "**/node_modules/**" ] } } } } }, "defaultProject": "seapage" }

Espero puedan ayudarme a resolver este problema, gracias de antemano. Saludos!

ngx-bootstrap + angular 6 + datepicker

Olá,

Estou utilizando o datepicker do ngx-bootstrap pela primeira vez e estou encontrando algumas dificuldades.

Uma delas é que ao selecionar a data desejada, meu input fica no formato exato que eu preciso, da seguinte maneira: ’20/12/2018′, porém quando jogo no console o valor do input, é apresentado da seguinte maneira: ‘Thu Dec 20 2018 23:26:21 GMT-0200 (Horário de Verão de Brasília)’.

Como eu faço para deixar o valor do input com o formato brasileiro: ’20/12/2018′. Procurei na documentação do mesmo e não encontrei.

Evidencias de como está funcionando(errado).

inserir a descrição da imagem aqui

Evidencia das propriedades:

inserir a descrição da imagem aqui