why my anaconda channels don`t have the package which i want

i want to install trochcpu&torchfile for my conda environment,but The Error is the channels dont the packages, i dont konw why ?

Current channels:    - https://conda.anaconda.org/conda-forge/win-64   - https://conda.anaconda.org/conda-forge/noarch   - https://conda.anaconda.org/bioconda/win-64   - https://conda.anaconda.org/bioconda/noarch   - https://mirrors.ustc.edu.cn/anaconda/pkgs/free/win-64   - https://mirrors.ustc.edu.cn/anaconda/pkgs/free/noarch  To search for alternate channels that may provide the conda package you're looking for, navigate to      https://anaconda.org  and use the search bar at the top of the page.  

In China, useful Anacondachannels is very rare.I have change my channels three time.but it doesnt work.

How to remove package libboost-system1.58.0? currently have unmet dependencies

I have boost libary 1.58 installed from default repository and an older version installed from source. Now I wanna remove the boost 1.58.

First I did was to remove the libboost-all-dev package, but there are still four packages left installed, two of which i remove seperately, and two I just cannot remove. These two packages are: libboost-system1.58.0 and libboost-filesystem1.58.0. Whenever i do sudo apt-get --purge remove libboost-system1.58.0 there are unment dependencies errors, which relates to qt, which I have no idea why it has anything to do with.

The error output looks like this:

The following packages have unmet dependencies:  liboxideqt-qmlplugin : Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                  libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  liboxideqtcore0 : Depends: libqt5gui5 (>= 5.4.0) but it is not going to be installed or                             libqt5gui5-gles (>= 5.4.0) but it is not going to be installed  liboxideqtquick0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                              libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                     Depends: libqt5quick5 (>= 5.2.0) but it is not going to be installed or                              libqt5quick5-gles (>= 5.2.0) but it is not going to be installed  libqmenumodel0 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                            libqt5gui5-gles (>= 5.0.2) but it is not going to be installed  libqt5multimedia5 : Depends: libqt5gui5 (>= 5.2.0) but it is not going to be installed or                               libqt5gui5-gles (>= 5.2.0) but it is not going to be installed  libqt5multimediaquick-p5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                      libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                             Depends: libqt5quick5 (>= 5.4.0) but it is not going to be installed or                                      libqt5quick5-gles (>= 5.4.0) but it is not going to be installed  libqt5x11extras5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                              libqt5gui5-gles (>= 5.0.2) but it is not going to be installed  libubuntugestures5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                       Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  libubuntutoolkit5 : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                               libqt5gui5-gles (>= 5.0.2) but it is not going to be installed  qml-module-io-thp-pyotherside : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                           libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                                  Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                           libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  qml-module-qtquick-layouts : Depends: libqt5gui5 (>= 5.5.0) but it is not going to be installed or                                        libqt5gui5-gles (>= 5.5.0) but it is not going to be installed                               Depends: libqt5quick5 (>= 5.2.0) but it is not going to be installed or                                        libqt5quick5-gles (>= 5.2.0) but it is not going to be installed  qml-module-ubuntu-layouts : Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                       libqt5quick5-gles (>= 5.0.2) but it is not going to be installed  qml-module-ubuntu-performancemetrics : Depends: libqt5gui5 (>= 5.0.2) but it is not going to be installed or                                                  libqt5gui5-gles (>= 5.0.2) but it is not going to be installed                                         Depends: libqt5quick5 (>= 5.0.2) but it is not going to be installed or                                                  libqt5quick5-gles (>= 5.0.2) but it is not going to be installed 

My first question is, why is this package libboost-system1.58.0 has anything to do with qt? I looked up in the ubuntu package page, neither these qt packages depend on libboost-system1.58.0 nor does libboost-system1.58.0 depends on these qt packages.

My second question is, is this package libboost-system1.58.0 really relevant? I remember i installed boost with apt-get install libboost-all-dev, but apparently libboost-system1.58.0 is not in the dependecy list to libboost-all-dev. So where does this package come from?

Third question might not be related to this problem, but I looked through these qt packages, when I check them, I saw they all have duplicate packages with different versions, for example:

liboxideqtcore0/xenial-updates,xenial-security,now 1.21.5-0ubuntu0.16.04.1 amd64 [installed,automatic] liboxideqtcore0/xenial 1.13.6-0ubuntu1 amd64 

So does this relate to my problem here?

Thanks a lot to you guys in advance BG

programmatically determine if a python package needs to compile C

I am building a system that will take a list of python packages (several hundred), generate wheels if none exist, and publish said wheels to our internal artifactory. This is being done for several reasons, two biggest is speed of install, and our system runs on some off beat platforms (namely BSD).

I have the process of pulling the sdist down, thats fairly easy. My problem is once I have the sdist down and using setup.py to generate the list of primary and transitive dependencies using pipdeptree, is there a way for me to determine if the package and its dependencies are pure python or if they require C compiling? I think I have counted about 5 different methods of wrapping a C library already, but all im really looking for is something that can answer this:

def requires_platform_build(module):   if test_module(module):     'send to platform build system'   else:     'send to docker container to compile ANY wheel' 

I know this is easier said than done with test requirements and such, but im not concerned with the test packages, only the runtime packages needed.

Unable to install package post adding ppa

I’ve been trying to create a bootable pen drive for the windows 10 may update on my ubuntu laptop for my PC. I’m running the 19.04 version of ubuntu. Since the windows iso needs special processes to be burned to the usb I’m required to install the woe-usb open source package.

sudo add-apt-repository ppa:nilarimogard/webupd8 sudo apt-get update sudo apt install woeusb 

But I keep receiving this error

Reading package lists... Done Building dependency tree        Reading state information... Done E: Unable to locate package woeusb 

I’ve searched throughout Stack Exchange and ask ubuntu but I have ended up empty-handed.

Package exiv not found during meson build ubuntu 19.04

Can anyone explain the following ?

user@system:~/gexiv2-0.11.0/build$   exiv2 --version  exiv2 0.27.1  This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version.  This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License for more details.  You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA   user@system:~/gexiv2-0.11.0/build$   meson --prefix=/usr ..  The Meson build system Version: 0.49.0 Source dir: /home/user/gexiv2-0.11.0 Build dir: /home/user/gexiv2-0.11.0/build Build type: native build Project name: gexiv2 Project version: 0.11.0 Native C compiler: cc (gcc 8.3.0 "cc (Ubuntu 8.3.0-6ubuntu1) 8.3.0") Native C++ compiler: c++ (gcc 8.3.0 "c++ (Ubuntu 8.3.0-6ubuntu1) 8.3.0") Build machine cpu family: x86_64 Build machine cpu: x86_64 Found pkg-config: /usr/bin/pkg-config (0.29.1) Found CMake: /usr/bin/cmake (3.13.4) Dependency exiv2 found: NO (tried pkgconfig)  meson.build:13:0: ERROR:  Dependency "exiv2" not found, tried pkgconfig  A full log can be found at /home/user/gexiv2-0.11.0/build/meson-logs/meson-log.txt 

given that exiv2 version 0.27 does not exist for ubuntu in general

(it stops at v0.25)

I did the following :

  1. I went to the exiv website : www.exiv2.org
  2. I grabbed the link for the linux build of exiv 0.27
  3. I ran the following

    wget https://www.exiv2.org/builds/exiv2-0.27.1-Linux64.tar.gz sudo tar xzf exiv2-0.27.1-Linux64.tar.gz -C /usr/local/lib/ sudo nano /etc/environment

  4. added :/usr/local/lib/exiv2-0.27.1-Linux64/bin 5.source /etc/environment

  5. restarted the terminal.

and then exiv is correctly usable.

but meson does not detect it is there during the build.

To be clear : the package gexiv2 Version 0.10.9 shipped for ubuntu 19.04 is inferior to my needed version of 0.11.0 at least.

apt-get / dpkg broken with error processing package ca-certificates-java

I can not install/pruge/reinstall or do anything using apt-get anymore. E.g. when I do:

sudo apt-get autoremove 

I get:

Reading package lists... Done Building dependency tree        Reading state information... Done 0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded. 2 not fully installed or removed. Need to get 0 B/12.3 kB of archives. After this operation, 0 B of additional disk space will be used. dpkg: error processing package ca-certificates-java (--configure):  package is in a very bad inconsistent state; you should  reinstall it before attempting configuration dpkg: dependency problems prevent configuration of openjdk-11-jre-headless:amd64:  openjdk-11-jre-headless:amd64 depends on ca-certificates-java; however:   Package ca-certificates-java is not configured yet.  dpkg: error processing package openjdk-11-jre-headless:amd64 (--configure):  dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure.                                                                                                           Errors were encountered while processing:  ca-certificates-java  openjdk-11-jre-headless:amd64 E: Sub-process /usr/bin/dpkg returned an error code (1) 

Doing:

sudo apt-get purge openjdk-11-jre-headless 

or

sudo apt-get purge ca-certificate-java 

does also not work and leads to the same issue. Is there remedy for my situation?