Our “Popularity Trends” always show 0 views inside sharepoint 2013

We have a SharePoint 2013 on-premises server. and the users have reported that the “Popularity Trends” report will always be empty:-

enter image description here

so i read this link @ https://briantjackett.com/2013/08/26/powershell-script-to-workaround-no-data-in-sharepoint-2013-usage-reports/ and when i run the proposed script:-

> $  aud = Get-SPUsageDefinition | where {$  _.Name -like "Analytics*"}  > $  aud | fl     > $  prud = Get-SPUsageDefinition | where {$  _.Name -like "Page Requests"} > $  prud | fl 

I got False for the “EnableReceivers”, as follow:- enter image description here

also when i checked Central admin > Application management > Manage Service Application > “Usage and Health Data Collection Service Application”, i found that it is started as follow:- enter image description here

so not sure what is going on? the problem that the fix on this link https://briantjackett.com/2013/08/26/powershell-script-to-workaround-no-data-in-sharepoint-2013-usage-reports/ is not an official fix, and i am afraid of running it… so can anyone advice why our “Popularity Trends” always show 0 views..

SharePoint 2016: How to restore the Popularity Trends for the few months

Good Day, I found the problem with popularity trends last week. They were empty since February of current year. Until February, everything had been fine. I have enabled the popularity trends via this topic https://social.technet.microsoft.com/Forums/en-US/187fd372-d967-4bc7-ad19-d6bc54a6a010/sharepoint-2016-analytics-usage-reports-not-showing-data?forum=SP2016

They are working since last Friday. I would like to know, is it possible to restore the popularity trends from February to July? I read this article Sharepoint 2013 popularity trend zero count after patch

But in my case it is about months, not about days.

Thank you in advance

Will enabling Popularity Tends inside our enterprise wiki site collection allow us to view most viewed/popular wiki pages

I have an enterprise wiki site collection inside our sharepoint on-premises 2013. the enterprise wiki contain around 3,000 wiki pages. and i want a way to generate a report which display the most populate wiki pages. now when i access my wiki pages library >> i did not find any “Popularity Trend” icon. and i think this is due to the fact that our Enterprise wiki does not have these 2 site collection features enabled:-

  1. Reporting
  2. Cross-Site Collection Publishing

now to test if the popularity trends will satisfy my needs >> I created a new test Enterprise wiki site collection >> i enabled the above 2 site collection features >> where i got a “Popularity trend” for each page and for the site collection.. but i did not find a way which can allow me to get the most populate wiki pages (i am not sure how sharepoint should calculate most popular wiki page, by total number of views or recent views..).. so can anyone advice on this? as i do not want to enable the above 2 site collection features on our live site collection, if the build-in Popularity trends will not be able to show the most popular wiki pages among the 3,000 wiki pages we have.

second point, will there be any harm if i enable the above 2 site collection features on our live site collection? and test things over,, and to disable the features afterward? or this is not advisable, keeping in mind that we have 3,000 wiki ages already created while the above 2 site collection features were disabled.

Thanks in advance for any help. Regards

Popularity trend report always 0

DETAILS BELOW enter image description here

Ok, so ive now been troubleshooting why our Popularity reports are always getting a zero and i feel i am very close.

Log files are being populated databases are being populated usage files are being created

Event Store folder is empty! ( Yes i have checked the sharepoint job Data import and it is enabled )

However i then checked the job which is suppose to run overnight

$ job = Get-SPTimerJob -Type Microsoft.Office.Server.Search.Analytics.UsageAnalyticsJobDefinition $ job.GetAnalysisInfo()

and Wallah! it hasnt been ran but i cant seem to find that job in CA to enable it.

Genuine Video Popularity Through adding Visitors for $1

Please read Carefully services Details then order……….Otherwise any Confusion about my services please contact me before Order . If you looking some services but You can not find Services providers then This offer Only For You … attention: Please contact for Clear Idea before Order If you Don’t understand Advantage: 1. Very Cheap Offer 2. Quickly deliver before deadline 3. Time Save 4. Real Benefit 5. No needed Admin Password So, why wait Please Order me…. get fast services Note: Please do not order another Seller at the same time for the same page. We cannot give you correct number in that case.

by: priyasmm
Created: —
Category: Social Networks
Viewed: 234


Dont have access to “Popularity Trends” but can access “Popularity and Search Reports”

So I am trying to see the popularity trends for my Sharepoint 2013 online site, and no matter where I try to access it for, top level site or subsites, I get the “Access denied, request access” page. However when I navigate to the top level site settings I can access “Popularity and Search Reports” under “Site Collection Administration” but “Popularity Trends” under “Site Administration” brings me to the request access page.

According to the Office Admin Center I am a member of Sharepoint Administrators, and when I check my permissions for a library it says I am a member of “Sharepoint Owners”.

We are using Office 365, and our sites are all 2013. We currently have only a single site collection with virtually nothing on it, we only recently got Office 365 and are currently still in the process of moving everything over to it.

Is there a simple set of permissions I am missing or something? Googling hasn’t helped and I didn’t find any similar questions on here.