Processing triggers for libc-bin (2.28-0ubuntu1) … /sbin/ldconfig.real: /usr/lib/libgraph.so.1 is not a symbolic link

Can someone help me with this problem i have been facing this problem since i have installed libgraph-1.0.2 in my Ubuntu 18.10. Actually i was trying to use graphics.h library in my program so while installing this libgraph for letting the graphic library work with my c++ using SDL.

it would be great if some one would help me through this i am trying to solve this problem from last 2 days. i have searched the whole internet to sort out this problem. and yeah this is my first time on askubuntu.

i am facing this problem in many different installations in ubuntu like the below one when i was installing OpenGL

b_cass_@BCasS:~$ sudo apt-get install libglu1-mesa-dev freeglut3-dev mesa-common-dev

Reading package lists… Done Building dependency tree Reading state information… Done libglu1-mesa-dev is already the newest version (9.0.0-2.1build1). libglu1-mesa-dev set to manually installed. The following packages were automatically installed and are no longer required: libhdb9-heimdal libkadm5clnt7-heimdal libkadm5srv8-heimdal libkafs0-heimdal libotp0-heimdal libsl0-heimdal Use ‘sudo apt autoremove’ to remove them. The following additional packages will be installed: freeglut3 libegl1-mesa-dev libgl1-mesa-dev The following NEW packages will be installed: freeglut3 freeglut3-dev The following packages will be upgraded: libegl1-mesa-dev libgl1-mesa-dev mesa-common-dev 3 upgraded, 2 newly installed, 0 to remove and 88 not upgraded. Need to get 927 kB of archives. After this operation, 1,078 kB of additional disk space will be used. Do you want to continue? [Y/n] y Get:1http://ppa.launchpad.net/system76/pop/ubuntucosmic/main amd64 libgl1-mesa-dev amd64 18.2.8-0ubuntu0~18.10.2pop1 [54.2 kB] Get:2http://in.archive.ubuntu.com/ubuntu cosmic/universe amd64 freeglut3 amd64 2.8.1-3 [73.6 kB] Get:3 http://in.archive.ubuntu.com/ubuntu cosmic/universe amd64 freeglut3-dev amd64 2.8.1-3 [124 kB] Get:4http://ppa.launchpad.net/system76/pop/ubuntucosmic/main amd64 mesa-common-dev amd64 18.2.8-0ubuntu0~18.10.2pop1 [608 kB] Get:5http://ppa.launchpad.net/system76/pop/ubuntucosmic/main amd64 libegl1-mesa-dev amd64 18.2.8-0ubuntu0~18.10.2pop1 [67.6 kB] Fetched 927 kB in 9s (104 kB/s) Selecting previously unselected package freeglut3:amd64. (Reading database … 429037 files and directories currently installed.) Preparing to unpack …/freeglut3_2.8.1-3_amd64.deb … Unpacking freeglut3:amd64 (2.8.1-3) … Preparing to unpack …/libgl1-mesa-dev_18.2.8-0ubuntu0~18.10.2pop1_amd64.deb … Unpacking libgl1-mesa-dev:amd64 (18.2.8-0ubuntu0~18.10.2pop1) over (18.2.8-0ubuntu0~18.10.2) … Preparing to unpack …/mesa-common-dev_18.2.8-0ubuntu0~18.10.2pop1_amd64.deb … Unpacking mesa-common-dev:amd64 (18.2.8-0ubuntu0~18.10.2pop1) over (18.2.8-0ubuntu0~18.10.2) … Preparing to unpack …/libegl1-mesa-dev_18.2.8-0ubuntu0~18.10.2pop1_amd64.deb … Unpacking libegl1-mesa-dev:amd64 (18.2.8-0ubuntu0~18.10.2pop1) over (18.2.8-0ubuntu0~18.10.2) … Selecting previously unselected package freeglut3-dev:amd64. Preparing to unpack …/freeglut3-dev_2.8.1-3_amd64.deb … Unpacking freeglut3-dev:amd64 (2.8.1-3) … Setting up freeglut3:amd64 (2.8.1-3) … Setting up mesa-common-dev:amd64 (18.2.8-0ubuntu0~18.10.2pop1) … Setting up libgl1-mesa-dev:amd64 (18.2.8-0ubuntu0~18.10.2pop1) … Processing triggers for libc-bin (2.28-0ubuntu1) … /sbin/ldconfig.real: /usr/lib/libgraph.so.1 is not a symbolic link

Setting up libegl1-mesa-dev:amd64 (18.2.8-0ubuntu0~18.10.2pop1) … Setting up freeglut3-dev:amd64 (2.8.1-3) …

Look at those bold ones. I got this error also when i was installing opencv.please solve it.