Magento 2.2.1 “Sorry, but something went wrong. Please contact the seller.” Checkout using Authorized.net

Magento 2.2.1. I have confirmed the transaction URLs, keys, and MD5 with Authorize.net. Transaction is processed and deducted from account. Order is created within Magento, and emails are sent. However, the error message tells the customer at the time of the transaction that it has failed. When they attempt it again, it double charges them.

I have reviewed all logs and there is absolutely nothing being logged in system.log, error.log, debug.log with respect to the transaction.

Are there any other logs to review?

How can I properly inspect the browser session for response messages?

I have seen a similar issue in the past on a different website using 2.1 and the issue was with the transaction url. I corrected it to api2 and all worked well.

UPDATE: I have switched to the Magento Blank theme and the issue still exists.

While viewing the console under the browser inspect, I see the following:

Refused to display 'https://www.<mydomain>.com/authorizenet/directpost_payment/redirect/x_invoice_num/000075321/success/1/controller_action_name/directpost_payment/is_secure/1/' in a frame because it set 'X-Frame-Options' to 'deny'. 

Is this an issue with respect to what I am experiencing?

Magento2.3.1: Sorry, but you can only add maximum quantity of product in this cart error

When I tried to add the product to the cart, I am getting the following error.

enter image description here

Steps to produce the issue:

  1. visit https://www.depoto.com/ website.
  2. enter visakhapatnam area > hit on show button at popup.
  3. click https://www.depoto.com/marble-cutter.html
  4. Hit on Add to cart button.

Then you can find the issue.

Note: The product quantity is 1000 and is in in-stock status.

Stock options configuration:

enter image description here

Product Stock Options configuration:

enter image description here

Why does a Contributor keeps getting Sorry, this site hasn’t been shared with you?

I am having issues in accessing a SP 2013 list. The subsite was previously private to a group but the client wanted to make a “trouble ticket area” public. The list should be visible by everyone. The issue is that the user can actually access to the list but when he tries to create/edit/delete the element it keeps getting ‘Sorry, this site hasn’t been shared with you.’ even though I gave the group the Contributor permission level.

I have checked the permission level of the subsite, page, and list and everything matches the contributor level. I have tried removing the group and add it again, clearing the Distributed Cache. I’ve tried anything, but nothing works.

The only workaround we’ve found is temporarily giving the group the design permission level. What could be possibly the problem? how can it be solved?

Sorry newbie, I dont get the PoS block creation, to much contradiction

I am sorry for the repeat question but I cant find a clear answer. Most of the time PoS isnt explained in detail (only explaining the advantage) and a lot of sources contradict each other and now I am confused.

I think I get PoW but I dont get PoS:

1) there seems to be two types of PoS. One where everyone bets on the most likely block to be picked and another where one node is chosen to validates the block based on the amount of coins you hold and some other factors… is that right? In the first case who decides which block to pick?

2) In both cases it was mentioned, that there was no need for miners. So if you only bet or validate, who creates the block in the first place or is creating the hashes? Or does PoS not use hashes anymore? If yes how do they validate with the ledges of the other nodes?

3) If PoS uses hashes and taken there is no competition of who completes the hash first, isnt there a risk that the chosen one cant compute the hash in time because of e.g. insufficient ressources?

4) Isnt the security less then PoW? As far as I see it, if the function only chooses one node isnt it in theory possible to alter the blockchain? Hashes arent bond by mining power anymore and the current node is the sole active one…

Magento UPS shipping methods displaying “Sorry, no quotes are available for this order at this time”

my store view is multi store view for US.

I have configured UPS in Magento 1 store.

enter image description here

I am having this problem at checkout, it keeps displaying “Sorry, no quotes are available for this order at this time.” for all products.

Here is my test Billing address place at checkout

enter image description here

I have checked the error log, there is no log for shipping.

Please someone have a solution for this issue.

SharePoint 2016 People picker error “Sorry, we’re having trouble reaching the server”

My users facing error on SharePoint 2016 when they try to add more than 15 users to share a file/folder. However, this error happen intermittently and have different results on different network connection. I have extended the timeout from default 25s to 60s. After that, the issue reoccurs when a user was adding names in the people picker, left the computer idle for a while and when he comes back to continue adding more names, he encounters the error message.

Does the network connectivity have anything to do with the people picker extracting names from AD? Is it normal for the people picker to timeout if left idle for some time? How can the users avoid facing this error again?

VLC is not supposed to be run as root. Sorry

When this is run

#!/bin/bash  # # located in /lib/systemd/system-sleep/ # Created 4/2/19 exec 2> /tmp/systemd_suspend_test_err.txt  if [ "$  {1}" = "pre" ]; then   # Do the thing you want before suspend here   echo "we are suspending $  (date +%I:%M:%S_%D)."  elif [ "$  {1}" = "post" ]; then   # Do the thing you want after resume here    echo "and we are back from being suspended $  (date +%I:%M:%S_%D)"    # gxmessage works IF xhost + is run first.   gxmessage -timeout 5 -fg red -display :0 'Back from being suspended.'   cvlc /usr/share/sounds/My_Sounds/Relax_6_Seconds.mp3 fi 

I get

VLC is not supposed to be run as root. Sorry. If you need to use real-time priorities and/or privileged TCP ports you can use /usr/bin/vlc-wrapper (make sure it is Set-UID root and cannot be run by non-trusted users first). 

I am not sure of the correct way of Set-UID root.