System.Data.SqlClient.SqlError: The media set has 2 media families but only 1 are provided. All members must be provided. (Microsoft.SqlServer.Smo)

I want to Backup/Restore our managed metadata managed service’s database from live to test which are both sharepoint 2013 farms. So i did these steps:-

1- Inside the live database i select the related managed metadata database >> right click on it >> Tasks >> Back Up… >> and i got a file named ttd.bak of size 1.9 MB, as follow:- enter image description here

2- then inside our test database , i created a new database with the same name as the live >> right click on the “Databases” >> click on “Restore Database” >> i select the new database and the ttd.back, but i got this error:-

TITLE: Microsoft SQL Server Management Studio ------------------------------  Restore failed for Server 'WIN-SPDEV'.  (Microsoft.SqlServer.SmoExtended)  For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.4000.0+((KJ_PCU_Main).120628-0827+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Restore+Server&LinkId=20476  ------------------------------ ADDITIONAL INFORMATION:  System.Data.SqlClient.SqlError: The media set has 2 media families but only 1 are provided. All members must be provided. (Microsoft.SqlServer.Smo)  For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.50.4000.0+((KJ_PCU_Main).120628-0827+)&LinkId=20476  ------------------------------ BUTTONS:  OK ------------------------------ 

as follow:- enter image description here

so can anyone advice on this? now our live environment (which i backup-ed the DB from) has the SP database on separate VM, while our test server (where i am trying to restore the DB) has the database server inside the same VM as sharepoint.. not sure if this is related to my problem?