SharePoint 2016 – Create Service Application timed out

We have a SharePoint 2016 environment setup which consists of following servers: 1. Wfe with distributed cache server 2. Application server 3. Search server 4. Database server

As part of installation we installed SharePoint 2016 prerequisites, then installed SharePoint 2016 binaries on all SharePoint servers, then ran SharePoint configuration wizard on all servers.

Now we need to create Service Applications as part of configuration, but none of the service application gets created successfully from UI or PowerShell. When we create Service Application from UI it takes long and then it give error: “Request timed out”. When we look at created service application in central admin, we can see the service application name with status stopped, no proxy gets created for the service application, database and the application pool does get created.

When we create service application using PowerShell then it takes 3-4 hours but the command to create service application does not complete. Even deleting the service application take 2-3 hours from PowerShell, from UI it just times out.

There are no errors related to this found in ULS logs or Event logs.

Any ideas what could be the issue here, why service applications are not getting created?

Thanks in advances, Anna

Update – Following errors appeared in ULS Logs when i again tried to create managed metadata service application and word automation service application

(Watson Reporting Cancelled) System.Threading.ThreadAbortException: Thread was being aborted.
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.WaitForCompletion(Object state)
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.End()
at Microsoft.SharePoint.Administration.SPServiceApplication.ProvisionInstances()
at Microsoft.SharePoint.Administration.SPIisWebServiceApplication.Provision()
at Microsoft.Office.ConversionServices.Service.ConversionServiceApplication.Provision()
at Microsoft.Office.Word.Server.Service.WordServiceApplication.Provision()

Timer ‘Word Automation Service’: Canceling execution because App ‘Word Automation Service’ is not online (Status=Provisioning)

MetadataWebServiceApplication ‘Managed Metadata Service’ create failed. Exception: System.Threading.ThreadAbortException: Thread was being aborted.
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.WaitForCompletion(Object state)
at Microsoft.SharePoint.Administration.SPTimerJobAsyncResult.End()
at Microsoft.SharePoint.Administration.SPServiceApplication.ProvisionInstances()
at Microsoft.SharePoint.Administration.SPIisWebServiceApplication.Provision()
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication.Provision()
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication.UpdateData(String sharedAppName, SPIisWebServiceApplicationPool applicationPool, Boolean unpublishAllPackages, String hubUri, Boolean doSetErrorReport, Boolean isErrorReportEnabled, Boolean doProvision)
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplication.Create(String sharedAppName, String databaseName, String databaseServer, String sqlAuthUserName, String sqlAuthPassword, String failoverServer, SPIisWebServiceApplicationPool applicationPool, String hubUriString, Boolean isErrorReportEnabled, Boolean isInDefaultAssociation, Boolean isPartitioned, Int32 cacheCheckInterval, Int32 maxChannelCache, Boolean forceProxyCreation, Boolean fDeferUpgradeActions)

MetadataWebServiceApplication ‘Managed Metadata Service’ unprovision started.

Ubuntu 18.04 sudo apt update give a long list of connection timed out error

I’ve just installed Lubuntu 18.04.3 LTS and it’s working fine. I can connect to my wifi and browse the internet. In fact, I post here using it. However when I try to do this sudo apt update it gives me a bunch of connect timed out error. Here is some of it.

Err:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Could not connect to security.ubuntu.com:80 (2001:67c:1360:8001::21). – connect (101: Network is unreachable) Could not connect to security.ubuntu.com:80 (2001:67c:1562::19). – connect (101: Network is unreachable) Could not connect to security.ubuntu.com:80 (2001:67c:1562::16). – connect (101: Network is unreachable) Could not connect to security.ubuntu.com:80 (2001:67c:1560:8001::11). – connect (101: Network is unreachable) Could not connect to security.ubuntu.com:80 (2001:67c:1360:8001::17). – connect (101: Network is unreachable) Could not connect to security.ubuntu.com:80 (2001:67c:1560:8001::14). – connect (101: Network is unreachable) Could not connect to security.ubuntu.com:80 (91.189.91.14)

I try to ping some of the ip but it seems to be working fine. Here is the result

ping 91.189.88.174 

PING 91.189.88.174 (91.189.88.174) 56(84) bytes of data. 64 bytes from 91.189.88.174: icmp_seq=1 ttl=54 time=264 ms
— 91.189.88.174 ping statistics — 3 packets transmitted, 3 received, 0% packet loss, time 2002ms rtt min/avg/max/mdev = 264.493/264.750/265.008/0.210 ms

I’m not sure what is the problem. Hope I can get some help. Thankyou for reading this long explanation

gpg key timed out error while installing GNU Octave on Ubuntu 18.04

I tried to install Octave using the following commands:

  1. sudo add-apt-repository ppa:octave/stable

  2. sudo apt update

  3. sudo apt-get install octave

But after running the 1st command, I get the following error:

The latest version of GNU Octave built for all supported Ubuntu releases. GNU Octave is normally distributed with Ubuntu, this PPA is for you if you have a need to use a newer version of Octave than what you can already get from your installed version of Ubuntu.  Simply follow the instructions below to add this PPA to your system and install the octave package. If it's not that easy or you encounter any errors, contact the team and let us know.  Much credit goes to the Debian Octave Group who maintain the official Debian packages that this work is derived from. Without their efforts to bring Octave packaging to such a high level of quality in Debian and Debian derivatives, this PPA would not be here.  More info: https://launchpad.net/~octave/+archive/ubuntu/stable Press [ENTER] to continue or Ctrl-c to cancel adding it.  Error: retrieving gpg key timed out.  

I’m on Ubuntu 18.04. Please help me to solve this issue.

sh: connect to host hostname port 22: Connection timed out

I have trouble connecting to a server with ssh from ubuntu 16.04. I can’t get to the address online either.

When i try connecting through terminal i got the following error

ssh: connect to host hostname port 22: Connection timed out

I can able to ping the hostname with following command ping hostname and following is the output for the same

PING hostname (ipaddress) 56(84) bytes of data.   64 bytes from ipaddress: icmp_seq=1 ttl=63 time=0.689 ms   64 bytes from ipaddress: icmp_seq=2 ttl=63 time=0.689 ms   64 bytes from ipaddress: icmp_seq=3 ttl=63 time=0.630 ms   64 bytes from ipaddress: icmp_seq=4 ttl=63 time=0.682 ms   64 bytes from ipaddress: icmp_seq=5 ttl=63 time=0.671 ms   64 bytes from ipaddress: icmp_seq=6 ttl=63 time=0.707 ms   ^C   --- hostname ping statistics ---   6 packets transmitted, 6 received, 0% packet loss, time 5086ms   rtt min/avg/max/mdev = 0.630/0.678/0.707/0.024 ms 

Error adding ppa repository, gpg: keyserver receive failed: Connection timed out

I am trying to install open source graphics drivers for AMD, but the sudo add-apt-repository ppa:oibaf/graphics-drivers command times out while receiving gpg keys from keyserver. I know it is due to blocking of port 11371. I even received the key by using port 80. But even then this command requests for the same key. I have also tried to unblock 11371 port using ufw with no help. What to do? Can I tamper the code of adding this repo, so that it does not request for the key, as I already have it?

Executing: /tmp/apt-key-gpghome.K797DqgsU8/gpg.1.sh --keyserver keyserver.ubuntu.com --recv-keys 5ABCE68FF4633EA42E219156957D2708A03A4626 gpg: keyserver receive failed: Connection timed out

Exception calling “ExecuteQuery” with “0” argument(s): “The operation has timed out.”

I am trying to delete list items, about 130K, from a large list on SharePoint Online using powershell CSOM, i am getting this error

“Exception calling “ExecuteQuery” with “0” argument(s): “The operation has timed out.””

this is my code

    for ($  i=$  allItems.Count-1; $  i-ge0; $  i--)       {           $  allItems[$  i].DeleteObject()         #$  clientContext.ExecuteQuery()        }        $  clientContext.ExecuteQuery()  

When i use the ExecuteQuery() outside the loop, i am getting this error. but it still deletes around 1K items each time i run the script.

But When i use the ExecuteQuery() inside the loop, it doesn’t throw the error and the script completes execution, BUT it takes about 20 times the time taken to delete items when ExecuteQuery() used outside the loop

i also used RequestTimeout property

$ clientContext.RequestTimeout = [System.Threading.Timeout]::Infinite ( or any value)

it doesn’t seem to honor this property.

Could anyone please help me suggest a better way to delete such a large list ( the list is still being used, i can’t delete the list)?

Thanks so much Maria Francis

Trouble adding a repository (retrieving gpg key timed out)

I’m trying to install the Elmer csc software, and I pasted the command line exactly as it is from their site:

sudo apt-add-repository ppa:elmer-csc-ubuntu/elmer-csc-ppa

I get the following:

Archive for the monolithic Elmer FEM software ubuntu packages.

More info: https://launchpad.net/~elmer-csc-ubuntu/+archive/ubuntu/elmer-csc-ppa

Press [ENTER] to continue or Ctrl-c to cancel adding it.

Error: retrieving gpg key timed out.

^C

I pressed Enter every time.

Can somebody hep me please?

Workflow “suspended” after creating a timed loop in a workflow

Recently discovered “timed” loops in Workflows, that allow me to loop based on a chosen variable (say 3 weeks, therefore loop 3 times). However, the workflow shows “suspended” under the workflow status page with this error:

RequestorId: eb0e8b41-7248-3ce0-0000-000000000000. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.InvalidCastException: The value ‘Value’ cannot be read as type ‘Int32’. at Microsoft.Activities.GetDynamicValueProperty1.CheckedRead(String propertyName, DynamicItem value) at Microsoft.Activities.GetDynamicValueProperty1.Execute(CodeActivityContext context) at System.Activities.CodeActivity`1.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation) Exception from activity GetDynamicValueProperty Cast BuildDictionary Subroutine Sequence Microsoft.SharePoint.WorkflowServices.Activities.LoopNTimes Then If Stage 1 Sequence Flowchart Sequence Duplicate 1.WorkflowXaml_8c4eecce_76a5_40a3_98a8_a5d2b9ac5d4c

I can’t seem to wrap my head around the error and hoping someone can direct me the right direction.

Here’s my workflow, basically, i’m checking if the user is using the right form via content type and continue to the loop. Here the loop runs based on what the user entered.

enter image description here

Any ideas what I should be looking?

failed: WebSocket opening handshake timed out JS

estoy desarrollando un websocket con ratchet en el servidor y JS en el cliente y cuando conecto al cliente hacia el servidor despues de unos 4minutos me envia en consola este mensaje “WebSocket connection to ‘ws://127.0.0.1:8080/’ failed: WebSocket opening handshake timed out” incluso en el lado del servidor me dice que se ha conectado. he probado desactivando el antivirus, probando con otro navegador y nada.

codigo del cliente:

<!DOCTYPE html> <html lang="en"> <head>     <meta charset="UTF-8">     <meta name="viewport" content="width=device-width, initial-scale=1.0">     <meta http-equiv="X-UA-Compatible" content="ie=edge">     <title>Document</title>  </head> <body>     <script>     var conn = new WebSocket('ws://127.0.0.1:8080'); conn.onopen = function(e) {     console.log("Connection established!"); };  conn.onmessage = function(e) {     console.log(e.data); };          </script> </body> </html>

codigo del server:

<?php  use Ratchet\Server\IoServer; use MyApp\Chat;      require dirname(__DIR__) . '/vendor/autoload.php';      $  server = IoServer::factory(         new Chat(),         8080     );      $  server->run();  ?>

mensaje en consola del server:

`Connection 48 sending message “GET / HTTP/1.1

Host: 127.0.0.1:8080

User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Accept: /

Accept-Language: es-ES,es;q=0.8,en-US;q=0.5,en;q=0.3

Accept-Encoding: gzip, deflate

Sec-WebSocket-Version: 13

Origin: null

Sec-WebSocket-Extensions: permessage-deflate

Sec-WebSocket-Key: ZWRzSV6AOK5E+PrZ+XneKA==

DNT: 1

Connection: keep-alive, Upgrade

Pragma: no-cache

Cache-Control: no-cache

Upgrade: websocket

” to 1 other connection

Connection 49 sending message “GET / HTTP/1.1

Host: 127.0.0.1:8080

Connection: Upgrade

`

Postfix connection timed out

I have a little problem with my postfix. The thing is that I can receive emails but when I send an email I get a Connection timed out error.

connect to outlook-com.olc.protection.outlook.com[104.47.5.33]:25: Connection timed out 

This is happening with all the emails I send and not just with outlook. I already searched for solutions for this problem but couldn’t find anything useful.

This is my main.cf:

# This file was automatically installed on 2019-06-27T15:11:55.824661 inet_interfaces = all inet_protocols = ipv4 myhostname = webmail.apt-one.com myorigin = $  myhostname mydestination = $  myhostname mynetworks = 127.0.0.0/8 smtpd_banner = $  myhostname ESMTP biff = no unknown_local_recipient_reject_code = 550 unverified_recipient_reject_code = 550  # appending .domain is the MUA's job. append_dot_mydomain = no  readme_directory = no  mailbox_size_limit = 0 message_size_limit = 11534336 recipient_delimiter = +  alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases  ## Proxy maps proxy_read_maps =         proxy:unix:passwd.byname         proxy:pgsql:/etc/postfix/sql-domains.cf         proxy:pgsql:/etc/postfix/sql-domain- aliases.cf         proxy:pgsql:/etc/postfix/sql-aliases.cf         proxy:pgsql:/etc/postfix/sql-relaydomains.cf         proxy:pgsql:/etc/postfix/sql-maintain.cf         proxy:pgsql:/etc/postfix/sql-relay-recipient-verification.cf         proxy:pgsql:/etc/postfix/sql-sender-login-map.cf         proxy:pgsql:/etc/postfix/sql-spliteddomains-transport.cf         proxy:pgsql:/etc/postfix/sql-transport.cf ## TLS settings # smtpd_use_tls = yes smtpd_tls_auth_only = yes smtpd_tls_CApath = /etc/ssl/certs smtpd_tls_key_file = /etc/nginx/privkey.pem smtpd_tls_cert_file = /etc/nginx/fullchain.pem smtpd_tls_dh1024_param_file =  $  {config_directory}/dh2048.pem smtpd_tls_loglevel = 1 smtpd_tls_session_cache_database =  btree:$  data_directory/smtpd_tls_session_cache smtpd_tls_security_level = may smtpd_tls_received_header = yes smtpd_tls_note_starttls_offer = yes  # Disallow SSLv2 and SSLv3, only accept secure ciphers smtpd_tls_protocols = TLSv1.3, TLSv1.2, !TLSv1.1, !TLSv1, !SSLv2, !SSLv3 smtp_tls_protocols = TLSv1.3, TLSv1.2, !TLSv1.1, !TLSv1, !SSLv2, !SSLv3 smtp_tls_ciphers = high smtpd_tls_ciphers = high smtpd_tls_mandatory_protocols = TLSv1.3, TLSv1.2, !TLSv1.1, !TLSv1, !SSLv2, !SSLv3 smtp_tls_mandatory_protocols = TLSv1.3, TLSv1.2, !TLSv1.1, !TLSv1, !SSLv2, !SSLv3 smtp_tls_mandatory_ciphers = high smtpd_tls_mandatory_ciphers = high  smtpd_tls_mandatory_exclude_ciphers = MD5, DES, ADH, RC4, PSD, SRP, 3DES, RSA, eNULL, aNULL smtpd_tls_exclude_ciphers = MD5, DES, ADH, RC4, PSD, SRP, 3DES, RSA, eNULL, aNULL smtp_tls_mandatory_exclude_ciphers = MD5, DES, ADH, RC4, PSD, SRP, 3DES, RSA, eNULL, aNULL smtp_tls_exclude_ciphers = MD5, DES, ADH, RC4, PSD, SRP, 3DES, RSA,  eNULL, aNULL tls_preempt_cipherlist = yes  # Enable elliptic curve cryptography smtpd_tls_eecdh_grade = ultra  # Use TLS if this is supported by the remote SMTP server, otherwise use plaintext. smtp_tls_CApath = /etc/ssl/certs smtp_tls_security_level = may smtp_tls_loglevel = 1  smtpd_tls_session_cache_database = btree:$  {data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:$  {data_directory}/smtp_scach smtp_tls_key_file = /etc/nginx/privkey.pem smtp_tls_cert_file = /etc/nginx/fullchain.pem  ## Virtual transport settings# virtual_transport = lmtp:unix:private/dovecot-lmtp  virtual_mailbox_domains = proxy:pgsql:/etc/postfix/sql-domains.cf virtual_alias_domains = proxy:pgsql:/etc/postfix/sql-domain-aliases.cf virtual_alias_maps =     proxy:pgsql:/etc/postfix/sql-aliases.cf  ## Relay domains# relay_domains =     proxy:pgsql:/etc/postfix/sql-  relaydomains.cf transport_maps =         proxy:pgsql:/etc/postfix/sql-transport.cf         proxy:pgsql:/etc/postfix/sql-spliteddomains-transport.cf  ## SASL authentication through Dovecot# smtpd_sasl_type = dovecot smtpd_sasl_path = private/auth smtpd_sasl_auth_enable = yes broken_sasl_auth_clients = yes smtpd_sasl_security_options = noanonymous  ## SMTP session policies#  # We require HELO to check it later smtpd_helo_required = yes  # We do not let others find out which  recipients are valid disable_vrfy_command = yes  # MTA to MTA communication on Port 25. We expect (!) the other party to # specify messages as required by RFC 821. strict_rfc821_envelopes = yes  # Verify cache setup address_verify_map =  proxy:btree:$  data_directory/verify_cache  proxy_write_maps =     $  smtp_sasl_auth_cache_name     $  lmtp_sasl_auth_cache_name     $  address_verify_map  # OpenDKIM setup smtpd_milters = inet:127.0.0.1:12345 non_smtpd_milters = inet:127.0.0.1:12345 milter_default_action = accept milter_content_timeout = 30s  # List of authorized senders smtpd_sender_login_maps =         proxy:pgsql:/etc/postfix/sql-sender-login-map.cf  # Recipient restriction rules smtpd_recipient_restrictions =       permit_mynetworks       permit_sasl_authenticated       check_recipient_access           proxy:pgsql:/etc/postfix/sql-maintain.cf           proxy:pgsql:/etc/postfix/sql-relay-recipient-verification.cf       reject_unverified_recipient       reject_unauth_destination       reject_non_fqdn_sender       reject_non_fqdn_recipient       reject_non_fqdn_helo_hostname  ## Postcreen settings# postscreen_access_list =    permit_mynetworks    cidr:/etc/postfix/postscreen_spf_whitelist.cidr postscreen_blacklist_action = enforce  # Use some DNSBL postscreen_dnsbl_sites =         zen.spamhaus.org*3         bl.spameatingmonkey.net*2         dnsbl.habl.org         bl.spamcop.net         dnsbl.sorbs.net postscreen_dnsbl_threshold = 3 postscreen_dnsbl_action = enforce  postscreen_greet_banner = Welcome, please wait... postscreen_greet_action = enforce  postscreen_pipelining_enable = yes postscreen_pipelining_action = enforce  postscreen_non_smtp_command_enable = yes postscreen_non_smtp_command_action = enforce  postscreen_bare_newline_enable = yes postscreen_bare_newline_action = enforce 

Does anyone have a solution for this?