How to setup SQL Server on VMWare for best performance

We have Dell r940 server with 64 CPUs.

Processor Type: Intel(R) Xeon(R) Platinum 8253 CPU @ 2.20GHz 4 Sockets + 16 Cores per Socket and 128 Logical processors Memory 767 GB

We set the server up on a VMWare v7.0 hypervisor. One of the virtual machines runs Sql Server 2019 Enterprise Edition on Windows 2019 Standard where we have mission-critical workloads.

Can anyone suggest a virtual CPU (Cores per Socket) + RAM configuration for best performance from this machine?

Is it legal to use “VMware Workstation 15 Player” with earning money purpose?

I am planning to open a blog webpage, publish technology-based content on it and make money via blogger earning methods like Google AdSense. The software I mentioned in the title, which is available at here, is just one of the necessities to prepare my content.

However, firstly, I want to be sure whether this kind of usage is legal or not for this software. When I look at the link I added, there is an expression in the form of “The free version is available for non-commercial, personal and home use.”

According to this statement, is it legal for me to use this software as I have stated?

Unable to run Windows 10 using VMware 15 pro on Ubuntu 19.04

I don’t know if this question is a duplicate or not. Please forgive me if it is, I have not been able to find an answer that addresses this.

Please, I am new to Ubuntu…

I am trying to use Windows 10 on Ubuntu 19.04. When I click the Start button, I get the following error:

Unable to change virtual machine power state: This host supports Intel VT-x, but Intel VT-x is disabled. Intel VT-x might be disabled if it has been disabled in the BIOS/firmware settings or the host has not been power-cycled since changing this setting. (1) Verify that the BIOS/firmware settings enable Intel VT-x and disable 'trusted execution.' (2) Power-cycle the host if either of these BIOS/firmware settings have been changed. (3) Power-cycle the host if you have not done so since installing VMware Workstation. (4) Update the host's BIOS/firmware to the latest version. This host does not support "Intel EPT" hardware assisted MMU virtualization. Module 'CPUIDEarly' power on failed. Failed to start the virtual machine. 

I am new to this and don’t know what to do. There’s nothing that I have looked up that has helped.

Once again, I am sorry if this question is a duplicate.

Thank you.

vmware player fails to install but no errors given

I am trying to install VMware player onto my workstation (Ubuntu 18.04.3 LTS). I’ve followed the instructions for installing from a bundle (download, chmod and sudo ./bundle_file) after which the installation process goes through a number of steps and finishes without any obvious errors. Despite there being no errors, closer scrutiny of the output seems to suggest that the installation did not actually install.

command ran as follows:

sudo ./VMware-Player-15.5.0-14665864.x86_64.bundle  Extracting VMware Installer...done. Installing VMware Player Setup 15.5.0 Copying files... Rolling back VMware Player Setup 15.5.0 Removing files... Deconfiguring... 

The attempted installation takes approx 9 seconds.

The complete installation log is as follows: /tmp/vmware-root/vmware-vmis-20775.log

2019-09-23T13:13:06.271+09:30| host-20775| I125: The process is 64-bit. 2019-09-23T13:13:06.271+09:30| host-20775| I125: Host codepage=UTF-8 encoding=UTF-8 2019-09-23T13:13:06.271+09:30| host-20775| I125: Host is Linux 4.15.0-64-generic Ubuntu 18.04.3 LTS 2019-09-23T13:13:06.270+09:30| host-20775| I125: DictionaryLoad: Cannot open file "/usr/lib/vmware/settings": No such file or directory. 2019-09-23T13:13:06.270+09:30| host-20775| I125: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory. 2019-09-23T13:13:06.270+09:30| host-20775| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values. 

No vmplayer command is created anywhere that I can find.

I’ve also tried downloading and running the full workstation bundle (VMware-Workstation-Full-15.5.0-14665864.x86_64.bundle). Output of the run attempt is nearly identical (only the name changes).

I’ve spent many hours crawling through Q&A forums and cannot find a similar case. Anyone know how to fix this? I need the vmplayer working asap.

How to access ubuntu shared folder in vmware from local area network?

I share a folder inside ubuntu by right click – Local Network Share. when I check it with

net usershare info –long I am getting the result as

[testom] path=/home/edadmin/Public/testom comment= usershare_acl=Everyone:F, guest_ok=y

From windows explorer I tried the path like this

2.168.221.131\testom – Nothing comes up ? when I input IP only its saying folder is empty ? Please help me to resolve this I dont know much on linux. Please advice. Thank in advance

VMWARE workstation !5.1 Doesnt work for UBUNTU 18.04.3

I tried to open VMware after 10 days and it stopped working for me. As not so good in ubuntu, i tried to resolve a couple of posts but the same issue. error message while running from terminal. There are couple of files attached as well with the logs and with the screen shot of the error message enter image description here ” mohit@:~/Downloads$ vmware Gtk-Message: 12:22:38.926: GtkDialog mapped without a transient parent. This is discouraged. Gtk-Message: 12:22:43.386: GtkDialog mapped without a transient parent. This is discouraged. Stopping VMware services: VMware Authentication Daemon done VM communication interface socket family done Virtual machine communication interface done Virtual machine monitor done Blocking file system done make: Entering directory ‘/tmp/modconfig-gBfrut/vmmon-only’ /usr/bin/make -C /lib/modules/5.0.0-27-generic/build/include/.. SUBDIRS=$ PWD SRCROOT=$ PWD/. \ MODULEBUILDDIR= modules make1: Entering directory ‘/usr/src/linux-headers-5.0.0-27-generic’ CC [M] /tmp/modconfig-gBfrut/vmmon-only/linux/driver.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/linux/hostif.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/linux/driverLog.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/memtrack.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/apic.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/vmx86.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/cpuid.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/comport.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/task.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/vmcore/moduleloop.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/common/phystrack.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/bootstrap/monLoaderVmmon.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/bootstrap/monLoader.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/bootstrap/vmmblob.o CC [M] /tmp/modconfig-gBfrut/vmmon-only/bootstrap/bootstrap.o scripts/Makefile.build:284: recipe for target ‘/tmp/modconfig-gBfrut/vmmon-only/linux/hostif.o’ failed Makefile:1606: recipe for target ‘module/tmp/modconfig-gBfrut/vmmon-only’ failed make1: Leaving directory ‘/usr/src/linux-headers-5.0.0-27-generic’ Makefile:110: recipe for target ‘vmmon.ko’ failed make: Leaving directory ‘/tmp/modconfig-gBfrut/vmmon-only’ make: Entering directory ‘/tmp/modconfig-gBfrut/vmnet-only’ /usr/bin/make -C /lib/modules/5.0.0-27-generic/build/include/.. SUBDIRS=$ PWD SRCROOT=$ PWD/. \ MODULEBUILDDIR= modules make1: Entering directory ‘/usr/src/linux-headers-5.0.0-27-generic’ CC [M] /tmp/modconfig-gBfrut/vmnet-only/driver.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/hub.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/userif.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/netif.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/bridge.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/procfs.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/smac_compat.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/smac.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/vnetEvent.o CC [M] /tmp/modconfig-gBfrut/vmnet-only/vnetUserListener.o scripts/Makefile.build:284: recipe for target ‘/tmp/modconfig-gBfrut/vmnet-only/userif.o’ failed Makefile:1606: recipe for target ‘module/tmp/modconfig-gBfrut/vmnet-only’ failed make1: Leaving directory ‘/usr/src/linux-headers-5.0.0-27-generic’ Makefile:110: recipe for target ‘vmnet.ko’ failed make: Leaving directory ‘/tmp/modconfig-gBfrut/vmnet-only’ Starting VMware services: Virtual machine monitor failed Virtual machine communication interface done VM communication interface socket family done Blocking file system done Virtual ethernet failed VMware Authentication Daemon done

Please suggest what i can i do to resolve this

***LOG FILE MESSAGE************************** 2019-09-06T12:03:16.571+10:00| modconfig| I125: Log for VMware Workstation pid=6753 version=15.0.2 build=build-10952284 option=Release 2019-09-06T12:03:16.571+10:00| modconfig| I125: The process is 64-bit. 2019-09-06T12:03:16.571+10:00| modconfig| I125: Host codepage=UTF-8 encoding=UTF-8 2019-09-06T12:03:16.571+10:00| modconfig| I125: Host is Linux 5.0.0-27-generic Ubuntu 18.04.3 LTS 2019-09-06T12:03:16.570+10:00| modconfig| I125: DictionaryLoad: Cannot open file “/usr/lib/vmware/settings”: No such file or directory. 2019-09-06T12:03:16.570+10:00| modconfig| I125: [msg.dictionary.load.openFailed] Cannot open file “/usr/lib/vmware/settings”: No such file or directory. 2019-09-06T12:03:16.570+10:00| modconfig| I125: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values. 2019-09-06T12:03:16.570+10:00| modconfig| I125: DictionaryLoad: Cannot open file “/home/mohit/.vmware/config”: No such file or directory. 2019-09-06T12:03:16.570+10:00| modconfig| I125: [msg.dictionary.load.openFailed] Cannot open file “/home/mohit/.vmware/config”: No such file or directory. 2019-09-06T12:03:16.570+10:00| modconfig| I125: PREF Optional preferences file not found at /home/mohit/.vmware/config. Using default values. 2019-09-06T12:03:16.607+10:00| modconfig| I125: Initialized! Lets do this thing… 2019-09-06T12:03:16.607+10:00| modconfig| I125: Obtaining info using the running kernel. 2019-09-06T12:03:16.607+10:00| modconfig| I125: Created new pathsHash. 2019-09-06T12:03:16.607+10:00| modconfig| I125: Setting header path for 5.0.0-27-generic to “/lib/modules/5.0.0-27-generic/build/include”. 2019-09-06T12:03:16.607+10:00| modconfig| I125: Validating path “/lib/modules/5.0.0-27-generic/build/include” for kernel release “5.0.0-27-generic”. 2019-09-06T12:03:16.607+10:00| modconfig| I125: using /usr/bin/gcc-7 for preprocess check 2019-09-06T12:03:16.615+10:00| modconfig| I125: Preprocessed UTS_RELEASE, got value “5.0.0-27-generic”. 2019-09-06T12:03:16.615+10:00| modconfig| I125: The header path “/lib/modules/5.0.0-27-generic/build/include” for the kernel “5.0.0-27-generic” is valid. Whoohoo! 2019-09-06T12:03:16.725+10:00| modconfig| I125: found symbol version file /lib/modules/5.0.0-27-generic/build/Module.symvers 2019-09-06T12:03:16.725+10:00| modconfig| I125: Reading symbol versions from /lib/modules/5.0.0-27-generic/build/Module.symvers. 2019-09-06T12:03:16.742+10:00| modconfig| I125: Read 23264 symbol versions 2019-09-06T12:03:16.742+10:00| modconfig| I125: Reading in info for the vmmon module. 2019-09-06T12:03:16.742+10:00| modconfig| I125: Reading in info for the vmnet module. 2019-09-06T12:03:16.742+10:00| modconfig| I125: Reading in info for the vmci module. 2019-09-06T12:03:16.742+10:00| modconfig| I125: Reading in info for the vsock module. 2019-09-06T12:03:16.742+10:00| modconfig| I125: Setting vsock to depend on vmci. 2019-09-06T12:03:16.758+10:00| modconfig| I125: Trying to find a suitable PBM set for kernel “5.0.0-27-generic”. 2019-09-06T12:03:16.758+10:00| modconfig| I125: No matching PBM set was found for kernel “5.0.0-27-generic”. 2019-09-06T12:03:16.758+10:00| modconfig| I125: Found compiler at “/usr/bin/gcc” 2019-09-06T12:03:16.760+10:00| modconfig| I125: Got gcc version “7”. 2019-09-06T12:03:16.760+10:00| modconfig| I125: The GCC version matches the kernel GCC minor version like a glove. 2019-09-06T12:03:16.760+10:00| modconfig| I125: Using temp dir “/tmp”. 2019-09-06T12:03:17.149+10:00| modconfig| I125: Setting destination path for vmmon to “/lib/modules/5.0.0-27-generic/misc/vmmon.ko”. 2019-09-06T12:03:17.149+10:00| modconfig| I125: Extracting the vmmon source from “/usr/lib/vmware/modules/source/vmmon.tar”. 2019-09-06T12:03:17.153+10:00| modconfig| I125: Successfully extracted the vmmon source. 2019-09-06T12:03:17.153+10:00| modconfig| I125: Building module with command “/usr/bin/make -j12 -C /tmp/modconfig-vKs08g/vmmon-only auto-build HEADER_DIR=/lib/modules/5.0.0-27-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no” 2019-09-06T12:03:18.526+10:00| modconfig| W115: Failed to build vmmon. Failed to execute the build command. 2019-09-06T12:03:18.526+10:00| modconfig| I125: Setting destination path for vmnet to “/lib/modules/5.0.0-27-generic/misc/vmnet.ko”. 2019-09-06T12:03:18.526+10:00| modconfig| I125: Extracting the vmnet source from “/usr/lib/vmware/modules/source/vmnet.tar”. 2019-09-06T12:03:18.529+10:00| modconfig| I125: Successfully extracted the vmnet source. 2019-09-06T12:03:18.529+10:00| modconfig| I125: Building module with command “/usr/bin/make -j12 -C /tmp/modconfig-vKs08g/vmnet-only auto-build HEADER_DIR=/lib/modules/5.0.0-27-generic/build/include CC=/usr/bin/gcc IS_GCC_3=no” 2019-09-06T12:03:20.123+10:00| modconfig| W115: Failed to build vmnet. Failed to execute the build command. 2019-09-06T12:03:20.132+10:00| modconfig| I125: We are now shutdown. Ready to die!


IPhone connect issue on VmWare (Ubuntu Host, MacOS Guest)

I need to have macos as a guest OS on vmware workstation player and it installed and everything works great except my iphone that the guest cannot recognize it correctly, according to following image the OS has identified it on USB2 but iTunes doesn’t recognize it as iphone device connected!

as a matter of fact there is no issue if i use windows as host instead ubuntu but i prefer ubuntu over windows and looking for a solution.

macos identify the device

Regards.

How to access Windows drives from 18.04 within a VMware guest?

I have not found a solution to this though there appear to be many similar Q’s.

I have a Windows 10 host. I have created a ubuntu 18.04 LTS guest inside a VMware workstation 15 player. The installation used Easy Install (by default and I left it as such) which I understand installs the necessary vmware tools.

I have enabled shared folders within vmware workstation player to provide access to the desired Windows folders.

However, the Windows folders are not visible to me within the ubuntu guest – neither as an ordinary user nor as root (I’ve enabled the root user password).

I have successfully done this previously but with a Slackware guest. I’m new to Ubuntu and am assuming there is something with Ubuntu that I have not understood or done.

Any help or advice would be appreciated.

Thanks.

Kevin.