ubuntu 16.04 , Python 2 , TensorFlow 2

i have installed tensorflow 2, python 2 and Kuda 8 i am not able to use any tensorFlow modules. it seems they are not compatible. any one knows which version of Python and Kuda should I used with TensorFlow 2.