ubuntu 18 – “sudo apt install tor” fails with “Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable”

i am trying to install tor as explained at this link:

Install Tor on Ubuntu 18.04 Bionic Beaver Linux

but it fails as shown below:

$   sudo apt install tor Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:  The following packages have unmet dependencies.  tor : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable        Recommends: tor-geoipdb but it is not going to be installed        Recommends: torsocks but it is not going to be installed E: Unable to correct problems, you have held broken packages. 

what am i doing wrong?