WCAG 2.0 compliance: do I have to support browsers which don’t support JavaScript?

WCAG 2.0 has some requirements on robustness: “Content must be robust enough that it can be interpreted reliably by a wide variety of user agents, including assistive technologies”, but it doesn’t mention JavaScript explicitly.

Now I have a project where I have to meet WCAG 2.0 recommendations. Do I have to support browsers / user agents which don’t support JavaScript?