What should be the appropriate name for an interface which has a single set method?

I have an interface which has a single method called setTenant(). It will have multiple implementations. What would be an appropriate name for it? The name TenantSetter does not feel like the name of a class/interface to me.