When do you run “apt-get update?”

When do I run “apt-get update” on Ubuntu 18.04 LTS? Is it ever necessary under Long Term Support?